Failed to get update. Please check your internet connection


#61

iPhone 6 same issue! Do we know what’s going on? Is it a 100% repro in all mobile devices?


#62

Glad I’m not the only one.


#63

Me too, same issues as above. No clue.


#64

I am having the same issue. Only since yesterday. I played through some of the new single player content and now just says “check your connection.” I did nothing differently.


#65

Iphone 7plus, same issue, tried restarting the phone, tried deleting and reinstalling the app, still not working. When will you fix this Blizzard?


#66

Same issue surfaced this morning. Might be due to some bug in their new content.


#67

I also have this issue on my Iphone XR, super frustrated rn and I hope we all are compensated for this. I mean, cmon, we can’t even open the game up and play!


#68

Snap - similar issues on the same device


#69

Same problem for me, iPhone Xs with 40GB free space. Both Wifi at home, Wifi at work and my LTE connection have this problem.


#70

Lazy and stupid developer don’t even care about the issue at all.


#71

Fire the intern who is pushing these bugs into hearthstone app please. Anyway, I bet it’s something server side.


#72

Was fine until yesterday. Now locked out. Some warning would have been nice for a week old known issue!


#73

Update. On iPhone X flipped phone over and it worked! Screen orientation impacting network? I haven’t seen anything like this since the airship fight in frozen throne!


#74

Same problem from yesterday with a iPhone XS!!!


#75

I just tried to kill some time last night by playing HS only to run into this problem. Did all of the above troubleshooting. No luck. More than a little irritated to find his issue has been going on for over a week with no fix. Sounds to me like you don’t want my money anymore. Seeing as it clearly isn’t going to paying the dev team to work on things like this.


#76

Hi - just tried your screen flipping idea on my iPad Air 2 and immediately there was some glow in the background followed by the error message . So… I tried again another 3 times and the message changed to ‘checking version’ and bingo I got in. Weirdest fix I have ever come across but it worked.


#77

Hey I logged into this forum just to update everyone, I’ve had this same problem since last update, the guy above me is right. I just repeatedly flipped the screen over and over and over until I saw “checking version” and it worked…honesty shocked it did.


#78

Having the same problem iPhone 7 Plus iOS 12.3 wish I could play blizzard :frowning:


#79

I was having these issues too. iPhone 8. I deleted the app completely, restarted phone and downloaded it from cloud on wifi. Once it all finally downloaded and updated it started working fine.


#80

I haven’t been able to access to the game for 01 week. I just read you guys’ experience above. I deleted the game from the “iPhone Storage” (inside the Settings) and then re-installed the HS from the App Store. Right after the installation had been completed, I opened the game and flipped the screen over and over until I saw “checking version”. Unbelievable, it worked. I can play the game now.
I hope that my experience can help you guys meeting the same problems as mine. I am so dissapointed that we have not receive the due support from Blizzard in this case (I suppose that this issue may not relate to our mobile device or internet connection).