Failed to get update. Please check your internet connection


#41

Just update the software to ios 12.3 and the game will be fine, it worked for i hope it will work fo you too.


#42

This is now the 5th day in a row of the app being completely unplayable


#43

Deployed, only fun thing I can do is play hearthstone and still can’t play after almost a full week. Honestly don’t understand, spent all this money to play this game each year and missing out on daily quests and still can’t play new adventure. Thanks for the love Blizzard.


#44

I deleted the app and now it will not download from the app store. App updated fine on my ipad3 though.


#45

Day 6 of the app being completely unplayable


#46

I don’t know if this helps but I just kept the app open and eventually the update started. This was on an Iphone 6S


#47

Kept the app open for a half hour and it never got past the error message. Day 7 of the app being completely unplayable


#48

I am also having the same issue on an iPhone 8+ after 12.3 ios update… Blizzard Pls.


#49

I’m on an iPad Air 2 with latest OS version and I’m having the same issue. Blizzard needs to fix their stuff quick.


#50

It’s funny because i’m sure that we are not gonna receive anything for all the time lost and for the money spent (in some cases) :sweat_smile:


#51

I’ve been having the same issue for a week. You would think that this would be a high priority for blizzard to fix?


#52

This clearly isn’t a high priority for them. It’s day 8 of the app being totally unusable and the only responses we’ve gotten are “move closer to the router” and “no ETA” so I’m not going to waste time hanging around here for weeks waiting for them to fix something. Just gonna delete the app and move on, bye Hearthstone :wave:


#53

Why is there no fix yet? Also cannot use HS for over a week since downloading the new version


#54

Unable to use the app myself. Just suddenly happened halfway through the day.


#55

Same symptoms as above. Half way through drafting arena ~12:15 Pacific today, the app suddenly crashed. Since then always get “Failed to get update. Please check your network connection.”

iPad, IOS 12.3
Uninstalled, reinstalled app, no change to behavior. Rebooted, same.


#56

Same thing happened to me around midday on iOS 12.3. Plenty space. WiFi is fine.


#57

Same here. Suddenly stopped working a few hours ago. Same error msg. Iphone 6s


#58

I have the same problem. I’m on an iPhone SE and the error message popped up. I went into the app store and it wouldn’t let me update it. The most recent update was the May 16 one and wasn’t giving me the May 22 one. I tried restarting my phone. Nothing. The internet connection was fine, I tried it on both wifi and LTE. I don’t know what to do.


#59

I’ve tried all of that. I was sitting next to the router and it didn’t work. The app store just doesn’t have the most recent update and the Hearthstone app thinks I should. Plz fix Blizzard!


#60

So this is 100% on Blizzard side if not obvious from all these replies and locked topics. I had been without WiFi access for over a week and never able to attempt the final 568 MB or whatever for most recent patch. I downloaded the adventure, PAID for the whole lot of it, and been happily playing HS until moments ago when I hit a WiFi connection and the game auto updated. WHOOPS! Guess I should have been reading these forums because apparently by allowing the game to update I have indefinitely locked myself out of the It?? People have been stuck like this over a week and no real response from Blizz other than get closer to a router (wow…) and someone’s “friend” is aware of an issue and no ETA? I have been playing HS since Naxx and Blizz games since Warcraft II but this is nuts that such a widespread and reported issue not only goes this long unsolved but goes on this long with barely any official response? This makes me want to petition the app store for my most recent $19.99 back as the game is not operational.