Failed to get update. Please check your internet connection


#130

When I open my app on IPhone X 256 Gb with active internet connection as I am replying via the iPhone the hearthstone app says Failed to get update. Please check your network connection.

This message appears instantly after clicking on app icon and after about 3 seconds this appears.

I havent tried uninstalling as I think that’s not the right thing to do as this issue has never happened before and everything was working fine.

EDIT 1: Shut down iphone x and switched back on after 30 secs, still the same issue with instantaneous error as described above.

EDIT 2: Deleted the app. Now in process of downloading it back on the iPhone will let you know of the result in edit 3. Also would like to add I had the option to offload the app but since the blue post recommended to delete the app so thats what I’ve done.

EDIT 3: Working very good just like brand new. Had to download when launched.


#131

I’ve been having this issue since almost a month ago and I have already deleted and reinstalled the game 3 times for it to work for about 4 days each one.
I’m quite tired of not just downloading it again but also download the data while in the game, lest I play it with no sounds and some animations.
The rotation while loading fix does not work for me, shut down the phone and turned on to try again, no dice with that.
So, how is it that this issue still isn’t resolved after so much time when all these reports have been made?


#132

Still an issue here as well.
iPhone X - iOS 12.4


#133

You have been ‘working on it’ for a month now.
Are you really telling me that a huge company with tons of employees can’t fix the problem in that amount of time? Or roll back to before the update that caused the crash?

As the many people have said above, it is not a connection issue, and it is not a storage issue.
Now a game I have paid several hundred pounds on doesn’t work and you don’t seem to care about updating it


#134

I have not been able to play on my ipad for the past few weeks now because of this problem. Have reinstalled and have latest ios version. Help.


#135

Can’t log in, says failed to get information, please check mobile connection

Can’t log in

Android device

Thanks


#136

It’s on iOS iPhone 6s it’s been like this for a few days since early June and I really would like to play i don’t know if y’all or looking into this or not but I’d like to know if anything is happening also I tried different internet connections and lte plus it works on pc


#137

Yeah same issue here…haven’t been able to play for two weeks…


#138

Same for me. Not working on my IPhone but works fine on IPad and Laptop. What’s going on?


#139

Having this problem on the iPhone 7+. I reinstalled the app and it freezes when I go to log in. However, it plays the opening animation and will let me do the tutorial part if you say you don’t have an account, but I can’t log in or play real matches.
It’s not my connection, I tried a few different networks and nothing has fixed it. Frustrating.


#140

I have the latest update and the error is presented.


#141

still waiting…

and just when i thought i’d be able to keep up with a new season and all. maybe next year.


#142

Same issue here, attempting to play on iOS and get the error “Failed to get update. Please check your network settings.” I have restored my device to factory settings and set up as new. Issue still occurs. Has been occurring since early June. I’ve been almost a month without hearthstone :sob: Please help.


#143

Just offloaded the application from the settings and re-installed. I was able to log-in successfully and play! Yay!


#144

Tried reinstalling application today and was still unable to get past the error.


#145

Just to reiterate what I did to resolve the issue on my end. On my iOS device I went to general -> phone storage -> hearthstone -> offload app -> reinstall app

I did not reinstall directly from the App Store, but from the settings in my phone.

I hope this helps anyone having the same issue.


#146

Can confirm this worked for me.


#147

Still having this issue as of now…

Any other solution than those above?


split this topic #148

A post was split to a new topic: Millhouse - Failed to get update please check your internet


closed #149