Cursor flickering when scaling above 125% on Windows

When playing on Windows 10 with anything above 125% scaling, the in game cursor flickers like constantly. I am using 150% scaling with my 1440p monitor, and thus this problem persists. Can you check if there is a solution for any of you? Sorry but I can’t switch to anything less than 140%, as things get too small for a 27" screen.

EDIT (30.03.2021): Just wanted to edit for update, since this post seems to got popular with many people having similar problems. I have been using a 27" Samsung 1440p monitor. And for my preference, I always used it at 150% scaling at windows. And this caused flickering. I turned it down to 120-125 range, and suddenly the flickerin stopped but it was too small still for me to use windows. But later I decided to try “custom scaling” inside the windows settings, and set it to 145%, just to be as close as possible to my preferred 150%. And voila, 145% works perfectly for me. It’s both readable and there is no flickering of cursor at all! Give it a try guys!

11 Likes

I am having this issue also. It’s such a bummer. Slows my whole system down and lags the game to the point of being unplayable.

3 Likes

It is specifically the default cursor - if you hold left click, the lag goes away. Please try to fix this one.

1 Like

I have just posted about this as well, I didn’t think to check scaling…let me go down to 125%

Apparently a lot of half-blind people playing Hearthstone on 1440p monitors!

Yep that fixed the flickering for me too. Well done for spotting it was the scaling, I didn’t even think of it.

3 Likes

I would like this fixed as well I’m having the same issue and it’s really annoying. I don’t think Blizzard even reads this or cares about the community.

1 Like

Super annoying bug. Especially with all the performance issues making the flickering worse in BG.

3 Likes

Crazy not a single response from Blizzard, what a joke company.

2 Likes

Same problem. 4K screen, cursor gradually flickers more and more until unplayable. Got much worse with the nvidia cyberpunk driver update (460.89). Happens on two completely different systems (only similarity is they’re both nvidia graphics cards). Changing DPI settings to 100% seems to fix it, but then I can barely see anything on the screen.

1 Like

one of the most annoying bugs i’ve ever had in a game.
PLEASE FIX THIS

Have the same issue. It also seems to affect the sound too, causing it to “flicker” as well. Anyone else notice it with the sound too?

Yes, sometimes after playing longer it happens. in battlegrounds

1 Like

Same for me, using a 13 inch 1440p display :frowning:

dear diary…i thought my new rig going crazy with that flickering…no damn! stupid bug.

FIXXX

Just bought a new 4k monitor, Hearthstone literally unplayable with this issue. Surely this isn’t a big fix, someone please get onto it.

Easy workaround
Set to 100%, launch Hearthstone, set to previous value.

Tried setting scaling to 100%
Didn’t work for me.

Thanks to HyberCube.

As he has said on the 5th post, find the hearthstone.exe file.
Go to it’s properties.
Click on compatibility.
Click “Change high DPI settings”.
Check “High DPI scaling override” and select System or System (enhanced).

2 Likes

Any chance of getting this fixed sometime?

This fixes the flickering and fps drops but now the game is in a lower resolution

Same problem here, Please fix this as soon as possible.