Can't start a Dalaran Heist run


#262

Also can’t start a heroic run. New release today, but this still isn’t working. Help Dev Team, you’re our only hope!


#263

Anything yet? And what do you guys plan to do for all the players who cant enjoy the content?


#264

chapter 3 is out, and still not able to play… fairly disappointed. I hope we get some sort of compensation.


#265

Nope. I have literally no idea what to do. I don’t know if blizzard will post anything on this, but I haven’t been able to play the heists since this bug. Kinda wack


#266

same issue here, was hoping they’d fix it by the new chapter :frowning:


#267

Hero portrait is black and play button does nothing on android


#268

Hi Kalraydis,
Is there any update today from Blizzard on when this problem might be fixed? Even a rough timeline would be helpful to know.


#269

Still got the problem on the normal run , hero portrait is empty, when i click play button the screen is freezing.


#270

I can’t try heroic as my game is locked on the character screen where you press play :triumph::triumph:


#271

I have this Bug since day one. I Lost to the last boss so i tried to restart the run then hero portrait dissapeared and I cant get to play. Reported this Bug like last friday. Whats the matter blizzard cant Even play the game that i paid for


#272

Same for me on computer, so sad


#273

Its friday and they probalby wont do anything about it through weekend, this is the worst bug i have ever seen. I am really dissapointed blizzard…


#274

still got the bug after clicking play button nothing happens I want to play chapter 3 please blizzard do something.


#275

Guess we won’t get a fix anytime soon just hope we get it before whole heist get released.


#276

I’m stuck with the same problem too.
Please blz, at least let me initialize the Heist progress.


#277

Same like you but i have gold on chapter 2 .


#278

Same issue as many, had it since Sunday. When going to start normal run in Dlaran heist, it starts a run as rakanishu but doesn’t display the hero portrait. I hit the play button, it clicks and then nothing. The only thing I can do is hit view deck or leave. Really wish I could play the week 3 content but cannot until this is resolved. Heroic still works fine but can’t play week 3 as a result of not unlocking in normal mode. This is truly the last straw, I waited with bated breath for this and loved it for the 3 days I could play. Total bs


#279

We are way overdue for an update. A real one too, with an estimated timeline. Not just a “we’re continuing to work on it” update. This is the eighth day that I’ve had this issue. If there was an issue at my job and my updates were this vague and infrequent, I’d probably be risking my job, and at a minimum a lot of anger from a lot of people. Blizzard it would mean a lot if you communicated more. The message I continue to receive is that you don’t care.

My phone just sent a “Play Chapter 3 now!” notification. I would if I could!


#280

I have the same issue and have had it since release. Hoping for a fix soon.


#281

Got a response from Blizz support that they rolled out a hotfix today that is supposed to resolve the issue of being unable to start a new heist run.

I just tried again and I’m still unable to continue my current run on Win 10 or Android. Still getting the issue where the hero portrait is blank and clicking the play button doesn’t do anything.