Can't start a Dalaran Heist run


#242

Thank you for the continued reports. Our developers continue to work on the issue. Once we have updates we’ll post them here.


#243

Still not working for normal on IOS.


#244

I’m still having the same issue. No portrait when I attempt to start my run. Boss 1/8. Play button makes the click but nothing happens.


#245

https ://imgur.com/JnQRysF
Just can’t start the game


#246

https ://imgur.com/RxmN1W1

And I had a new encounter yesterday. Don’t know what you doing Blizz, but at least this expansion is incredibly hilarious…


#247

same problem right here


#248

Still having this issue. Normal mode is bugged but Heroic (and all other solo adventures) work fine. On PC running 64-bit Windows 8.1.


#249

Normal mode and other solo adventures work fine, only the heroic mode is bugged. ( PC Windows 10 )


#250

The first 3 days I could not start the game, the same error as all. but then the heroic option is endless without the ability to lose, without the ability to choose cards, without bonuses, and Bob was my enemy
https ://imgur.com/tXENCag
https ://imgur.com/1tSbOLJ
having defeated the last boss, they gave me thea first boss again. endless cycle


#251

I have this exact issue


#252

I have an issue as well, and perhaps it is somehow related to the portrait of Rakanishu not showing up?


#253

Same problem I had killed 35 boss like I would stuck on 6/7/8 boss then.
Then I start a new run and my hero power would show but my char wont and it wont click on play !!"


#254

Same problem since the update yesterday, hoping for a fix before new content


#255

Officially one week later and still no fix… my ticket has been met with a canned response… at this point i just want my money back…


#256

Chapter 3 now available. Yay! Sure wish I was able to play it!


#257

I’m having a similar issue. I had an existing Normal Dalaran Heist run in progress when chapter three was released. Now the hunter hero portrait doesn’t show, but the hero power icon does. When I click the play button it makes a sound but nothing else happens, then I can’t click it any more.

This is happening on Win 10 64 bit. I also tried on my Pixel 2XL and the same thing is happening there.

https ://i.imgur.com/w1X1q5K.png


#258

I am having an issue where my portrait disappears that has only happened now that chapter 3 released.


#259

I am having the same issue where the portrait does not show up and it won’t let me into the run. I am unable to do it on android or pc.


#260

Same issue: Can’t start the run. Play button does not work and cannot “leave” the run in any way. Glad chapter 3 is here would only be better if we actually could play it :disappointed_relieved:


#261

Same issue here!!!