Diablo II (2000) Unable to identify version [2021]

Hello everyone,

We are aware of an issue in Diablo II (2000) affecting multiple gateways (US East, Europe, etc) which can cause an “Unable to identify version” error when connecting to Battle.net. This may happen after a fresh install of Diablo II due to a version mismatch between the Diablo II client version and server version. When downloading Diablo II from the downloads page you are given version 1.14B but in order to connect to Battle.net you must have version 1.14D.

To resolve this issue please manually download and apply the 1.14D patch via the links below. Links are separated depending on if you have the Lord of Desturction expansion installed or are just running the base Diablo II game.

Copy the full link, open a new tab in your browser window, then paste it into the address bar and hit Enter to start the download.

Diablo II - Patch 1.14D download links
PC version
http://ftp.blizzard.com/pub/diablo2/patches/PC/D2Patch_114d.exe
Mac version
http://ftp.blizzard.com/pub/diablo2/patches/Mac/D2_Patcher_114d.app.zip

Diablo II: Lord of Destruction - Patch 1.14D download links
PC version
http://ftp.blizzard.com/pub/diablo2exp/patches/PC/LODPatch_114d.exe
Mac version
http://ftp.blizzard.com/pub/diablo2exp/patches/Mac/LOD_Patcher_114d.app.zip

If you have successfully patched to version 1.14D and you’re still receiving the unable to identify version error, please go ahead and try the remaining steps on this article.

10 Likes

What about for windows 10, do I use compatibility mode for windows 7?

A fully updated Windows 10 is supported, so it shouldn’t require any extra steps to get the game running on it.

I am having this same issue on widows 10. I have attempted all fixes listed on another battle.net page but i still can not get past the “unable to identify version” on US East. Please assist.

3 Likes

Same issue here. Updated windows 10. Able to play single player and LAN but unable to identify application version when trying to log onto battlenet. Tried the troubleshooting tips including reinstall and admin.

On this support page there is a link to download the 1.14d update. If you haven’t updated, try that first.

If it still doesn’t want to work after that, you’ll want to contact technical support directly so that they can troubleshoot with you.

https://us.battle.net/support/en/help/contact/1938/ticket

2 Likes

experiencing the same issue on a fresh d2 install from the site

2 Likes

This worked. Thank you!

ProFupa…
How did you solve the problem?

I sent system info through that page and now the game magically works? What’s going on here?

Nice!

It wasn’t from the submission. What ever was preventing you from connecting (there are a couple possibilities) must have resolved.

Just throwing this in again for extra visibility:

Hey folks,

When trying to connect to USEast, check your game version in the bottom left of your screen. If it says anything besides 1.14D, please use the update found in this support article to manually update to 1.14D.

Afterwards, try connecting again. It will be helpfull to know if it works or not and what brand of computer your using (PC/Mac).

so my version says 1.14B but per this note on your linked page i should be able to connect and get an update. That isnt happening because when i click on the battle.net button it simply gives the version error message and not an update prompt so what do I do?

" Note: The installer will install version 1.14b. Once installed, please launch the game and log in to Battle.net. This will prompt you to patch to the latest version 1.14d.

If you can’t connect, they you aren’t going to be able to pick up the update. So this is just a way to bypass that required step.

So I am confused by this response. What do I do to get off version 1.14B and to version 1.14D? i have downloaded the installer off that link of yours and uninstalled and reinstalled. It wont trigger the update using the battle.net button so how do i get version 1.14D?

On that page, there are links to the 1.14D patch.

If you experience any issues using the links above, you can directly download the most recent patches for Diablo II (2000) (PC / MAC) and Diablo II: Lord of Destruction (PC / MAC).

Just wanted to say that I appreciated this suggestion but it didn’t work for me.

1 Like

Leviathan, we clearly are not having any luck with the dumb page you keep linking, and there are many of us who are getting this error. Find us a real solution instead of giving us a non working method.

SlayerJax,

thejtshaw is having a different issue than you. The “Checking Versions” and the “Unable to verify version” messages are different things. So please only speak for yourself, especially since there’s been a report of the support article working for someone else.

Additionally, you don’t have to spread this out over multiple threads. I replied to you in the other thread.

Playing Diablo 2 LOD, I have a fresh install and when I clock to join Battle.net it continuously just repeats “Cannot verify version.” I am on current version of Windows 10 and I am running it in Administrator Mode. My wife had no issues with this and we are running the same everything.