The Fallen Protectors @ Siege of Orgrimmar


#1

I can’t kill The Fallen Protectors in SOO on any difficulty. I’ve never had this problem before.

AOE/nuke them all down so they die together, etc… but one of them always survives now and if I hit the survivor, they’ll drop to 0 then refill their health to 21% and it just keeps going and going. There’s no way to reset or end the fight. I have to wait for hearth to come off cooldown.


Siege of Orgrimmar He Softfoot
M SoO Issue?
#2

I have the same problem, although with me, I make either Sun or Rook do their mechanic thing where they spawn adds, and they just get stuck there, I believe the adds are just not spawning so they get stuck. Additionally, I tried to do it with multiple characters and it was all the same. When I brought in my rogue tho, I used grappling hook to skip the fight and lo and behold, Norushen is also bugged, the dialog windows with the option to start the fight is simply not clickable.


#3

Glad it’s not just me.

You think Norushen is bugged because you’re skipping Protectors, though?

Who knows. This is annoying.


#4

For me, Rook and Sun never complete their add phases. They go into it, one add comes out then they freeze in place for the rest of the fight.


#5

Yeah thats what happens to me, you explained it better


(Ghaghzull) #6

Same on my end.


#7

just happened to me and had to heart out. pretty annoying


#8

Same for me, tried 2 different characters and killing the protectors in different orders and speeds with no luck.


#9

Same here, super annoying, tried like 7 times. Only need 1 more item to complete class set from this raid and was waiting for reset to run it………

Fix please! =)


#10

Oh god I was looking for this.

Sun and Rook go completely untargetable during their add phase and never leave it; kept googling to see if anyone else had seen this bug and I finally find this. I’m so relieved to see that I’m not just missing something obvious.


#11

Just had massive issues with it that I didn’t have last night. Same thing, Sun and Rook on the first Desperate Measures at 66%. One add spawns, and nothing else.


(Felsavior) #12

I’d bring this over to the but report thread, sounds like a bug in the fight to me.

Edit: I got moved here from GD. Embarrassing. My bad.


#14

Hey all! I contacted a GM about this and they tried multiple things ingame with the boss itself that only GM’s can do, and it still didn’t work. They are aware of this issue and have sent it up to the devs to get this fixed, as they don’t know why it randomly broke. They said to try later in the week. Thanks


#15

Yep same issue. Softpaw works fine, but the other 2 don’t stand back up after the 1st add summon. It worked for me on heroic, maybe I just killed them instantly. Stuck on mythic. Can’t skip because next boss won’t display text unless you kill them.


(Daventon) #16

The first time I tried it today both He and Sun stayed active, only Rook got stuck. Currently waiting to die with only He active. On 25 normal.

Edit: probably totally unrelated but putting it in just in case: just tried again on 10 normal, had to bubblehearth, but before I left and continuing after hearthing, my mouse went completely wonky. Character spinning in place, then cursor jittering then zipping all over the screen.
Edit 2: seems I may have a flaky USB port, moving “probably unrelated” to “99.99999% probably unrelated.”


#17

Yeah, same problem. I have one mob left, He Sotfoot, and he just keeps popping up Bond of the Golden Lotus .

And I was hoping today would be my lucky day (is my Bday!) that I’d get the Juggernaut drop!

Obviously: Not Today!


#18

All same here; it’s always He Softfoot for me too. This must be super fresh, I just ran this Friday and it was all fine, not sure what changed but I’ve let He kill me 3 times so i could reset and no matter what I try, I get stuck on He


#19

Thanks for the heads up! Helpful to know they are aware, and it seems like enough people tmog this that maybe they’ll get it fixed


#20

Same issue here! :frowning:


#21

I am having the same issue. He Softfoot is the last one alive while the other two are just sitting there passive and unable to be attacked. Tried it on a few characters and it is happening with all of them. Must be the reset or something.