The Fallen Protectors @ Siege of Orgrimmar


#22

Thank you!


(Daventon) #23

Yeah, very much so - I just did it successfully this morning before reset. I know it was today because I got the normal achievements yesterday and the mythic today. (Not this toon. Auryssa-Earthen Ring.)


#24

Paragons of Klaxxi are also bugged. I got stuck on LFR difficulty, Hisek the Swarmkeeper spawns but is not attackable. Skeer the Bloodseeker never spawns.

Edit: Only bugged if you don’t have patience.


#25

I believe that bug in particular is an older bug, what I do is always wait for the RP dialog to finish to pull. Something along “Come, Children of the titans”. I constantly bug that fight if I dont wait for the text, but when I wait I have no problems. Try it.


#26

Worked, thank you. I’m glad the whole raid isn’t bugged.


#27

Same thing on my end. Happy to at least see I’m not missing something.


#28

same issue here, done yesterday with all of my chars, except one, no trouble
then i waked up to finish with my last char, before the reset of the week, here the bug begins


#29

I’m also having the same problem. I’m after the shoulders and did everything (hearth out, reset, kite the bosses out, try on a different character), all to the same demise. Hope it’s fixed as this is the only thing I have been running!


#30

Add me to the list of people affected. it worked last night when i ran the dungen, just not today


#31

come on, where’s the Blizz support


#32

woah…good thing i checked back here before trying yet another attempt…this is nuts


#33

im having the same issue attempt 4. if you target lorewalker cho and jump straight at him i had success at resetting the fight. i am on a druid idk if that helps or ot


#34

Same problem here, Freux ( monk ) and Sun ( priest ) are bugged.

They don’t get up after have kills adds.

Only He ( rogue ) is ok.

Only solutions would be use AoE with some friend for Instant them … i don’t see others solutions.


#35

Same issue here, heaps of tries doing various things.

Sun and Rook stuck.

I have been able to jump back up top to reset the instance, you need to time your jump and his gouge to you get the extra boost up :wink:


#37

Came here to report the same bug! will kill 2 of the three, and the third will just continually use the ability to restore everyone, but it wont work.


#38

I too have encountered this bug and cannot move beyond this fight :frowning:


#39

Glad that I’m not the only one with this issue. I was able to get passed twice on my toons on Normal by nuking them all down at once before the bug could happen (it would happen during the add summoning phase). Otherwise, I can’t replicate that fix on heroic or mythic difficulty.


(Hulgan) #40

If you are having issues you can reset the fight by targeting sho and jumping at him repeatedly. Also if you kill all 3 at the same time you can win the fight. I just did it moments ago. I hope this helps


#41

Mark me down for being impacted by this bug as well.


#42

Yep. Same deal as everyone else, looks like.