Sept 8th-12th 2019 - WoW connection issues / WOW51900328

Thanks for the new reports.

We are still working on getting everyone back into the game. We are still investigating the situation. If we have any updates we will let you know.

Please continue to provide realms and exact errors if you have not yet done so.


At least Diablo 3 is not effected.

was WOW51900328 now WOW51900319

retail Server - Alleria Classic server - Pagle
ISP - Suddenlink

I feel sorry for diablo fans… i loved the series

My name - Remulos

I made a thread for Linux-specific problems: Linux users unable to log in, WOW51900328/329 error after logging in so it would get more attention by anyone who just came here.


Also a Linux user that can’t get past server select.

Character name: Zigz
Realm: Stalagg


Gregoran - Bloodsail Buccaneers

Astrazula - Bloodsail Buccaneers

error WOW51900328

1 Like

Can’t get past server select, Windows 10.

Realm: Stalagg
Error: WOW51900328

OS: Arch
Realm: Earthfury, Kromkrush
Error: You have been disconnected. (WOW51900328)

Playing using the Lutris client.


Shalie - Stormrage


Name: Cuvelia
Realm: Remulos
ISP: Two attempts - Centurylink (land) Verizon (wireless)
OS: Pop!_OS 19.04 64-bit, using Lutris
Error: WOW51900328


Arch Linux user, I was getting a realm list but couldn’t log into any server.

I spun up my Windows VM and it works just fine in there.

Please let us Linux players in!


1 & 2 were awesome. Sucked they shut down Blizzard North. Would have loved to see what Diablo 3 could have been.

Been screwy all day connecting to Mankrik. I was logged in fine this morning and for a brief period tonight. Rest of the day has been a complete waste. WTF


Classic server: Benediction
Retail server: Sargeras
ISP: Comcast

Can’t log into my account using my Ubuntu/Lutris install, logs in just fine on the same machine under a Windows vm. Also logs in just fine on my wife’s Windows 10 machine.


Also on Linux. Just went to a Windows computer on the same network and it worked first try. :expressionless:

1 Like

In retail, it won’t even take me to realm selection.

In Classic, all realms, even Oceanics, all give the same error.



pakalo on bigglesworth

Using lutris also with issues logging in:
darylboba on windseeker (classic)