I Can't Link Mounts on Chat

When I try to link a mount, a seemingly random string of letters appears on the text window instead. Trying to send the message either gives me an error message in guild chat, or emotes “something unintelligible” on regular chat. The mount link does not appear on either chat.

I can link items, spells, pets, transmog, heirlooms, quests and toys, but not mounts from the mount collection interface.

I tried reloading the chat, reloading the game, toggling “Interactive Chat” on and off several times, changing zones, etc. Nothing worked so far.

I have no addons installed.

The issue happens on my Draenei Warlock. My Undead Death Knight can link mounts in chat normally.


You may still wish to reset your interface regardless. Elements can corrupt over time as is just the nature of technology, creating new ones from scratch can at least rule out a good number of other possibilities.


I just did that, sadly it didn’t work :frowning:

Still showing a string of seemingly random text when I attempt to link a mount.

This is the full string of characters that appears when I try to link the Netherlord’s Chaotic Dreadsteed:



Did you run a repair install?

Right click the chat tab and make sure it’s interactive (if make noninteractive is listed as an option, then it’s interactive). This sounds like the behavior that would result when you try to link something in a noninteractive chat window.

I just tried that, and sadly it didn’t work :frowning:

I don’t think the problem is on my end, especially since I only installed WoW 17 days ago and didn’t install add-ons or anything :frowning:

That was one of the first things I tried. The chat is interactive. I can link anything, except mounts from the mount collection.

Hmm…I’m not sure then, that is realy strange.

1 Like

Having the same issue but only on my druid. Tried disabling all addons and also a clean reinstall but the issue is still there

1 Like

Does /reload work?

100% positive you have already tried this but worth a try asking it.

You need to do a proper reset UI.

Even reinstalling won’t necessarily do the same thing - depending on how it’s done.

With WoW totally shut down, rename, move or delete the WTF, Cache and Interface folders - then test before reenabling or reinstalling anything else.


Sadly, that didn’t solve it for me :frowning:

I’ve tried anything in this thread short of a full reinstall. Nothing has worked so far.

1 Like

Same thing as Luxuria; problem persists after fully resetting my UI and it only happens in one character which is the weird part

One character is actually a common thing indicating it IS a UI issue.

If a proper reset UI doesn’t help, posting in bugs would be the next best step.


I did create a bug report on this issue back in December

Cannot Link mounts into chat

Seems to be a some what common problem, there are other posts in Bug Reports about it as well.


Well it isn’t because the same thing is happening to my Druid…even on an old laptop that I haven’t used for WoW in years. You’re telling me two different systems, years apart in settings and addons, are having the exact same UI issue?

1 Like

This laptop, you did a fresh install or you updated an old install? I am not sure how much of the system involves server side vs client side data. If both UI’s have fresh reset interfaces, then the next step is the bug report forum.

1 Like

Just updated but I’d bet my entire account a reset wouldn’t change a thing.

1 Like

Just wanted to add… that if you view the wowhead link on a particular mount, you can click the “links” button above the mount’s image. This drop down will show three options to link a mount for web sites and in chat. The best I can tell you to do, is try each one of those links to see if any of them are displayed in chat. However this could be something Blizzard disabled due to bots flooding gold buying spam.

Item links aren’t the same as the links from the mount journal.

I found a solution to this issue after trying countless other methods and having no success, the following method worked finally. Type these 2 console commands 1 at a time in the following order:

/console synchronizeConfig 0
/console synchronizeSettings 0

My wonderful friend shared this with me the other day and finally solved this problem after 6+ months of not being able to link mounts.

As far as I can tell, it didn’t have any other side effects whatsoever. The only thing it appears to have done is fixed the mount linking issue, so don’t worry about this breaking anything.

I don’t think blizzard is aware that this is NOT a UI issue. It is associated with the individual character and will persist regardless of changes to UI.

One of the many things I tried while trying to fix this was to install Wow fresh on a different computer with no add-ons and the default interface and it still had the issue. Also it was only on certain characters at first and then it slowly spread across my account.

It’s possible that the issue might be initiated by a faulty add-on or interface bug, but the solution does not lie in resetting the UI. It seems as though something (perhaps a faulty add-on) can trigger something server-side, which then prevents the linking of mounts until these console commands are run to reset the values server-side back to their defaults.

Whether the issue will then recur in the future may depend on UI and add-ons, but critically the actual fix is not dependent on them.