Guild View / Chat Issues

This started happening earlier this afternoon when I joined a new guild. When I try to see my guild, I can’t see anything. It says 0/0 online. Everything else is blank, and the only other tab I see is the roster, which is also blank… I can’t even type to my guild anymore. Is this a server-wide issue? How can I fix this?

Edit: To update, my other characters aren’t experiencing this issue from what I can tell.

3 Likes

Same here. I have had my Druid in my bank guild for a while. I joined a new guild on him tonight. I spoke in Guild Chat. It seemed fine. I logged onto my Rogue for a bit. Then when I logged back to my Druid, I couldn’t even see the Guild in the tab with my communities. No roster or chat. And the Guild Finder option was there. It was as if I were Guildless. But the Guild was in his name, and the dude that invited me said he saw me in the roster. My other Characters have no issue. Just my Druid, tonight, right after I joined a new guild.

I started looking for solutions. My Druid didn’t have any add ons activated. I exited the game and restarted. I am hoping it resolves itself.

1 Like

Same here!!! Please send help! :cry:

1 Like

Same here, I am on Stormrage. I Joined a guild and could see the normal guild tab, I signed off for a few hours and came back and it was bugged. I messaged my GM through discord and I left the guild, was reinvited back and everything was normal. So I decided I should test a theory and I completely logged out and back in and it was bugged again and the guild tab showing 0/0. funny thing is if you do /groster it shows me in the guild

I added my voice to the bug report forum. Hopefully if more people report this, it may get fixed faster.

now the issue is happening on all my toons

Same issue for me. Also, this is NOT a new issue Blizz was having this problem back in Jan and is aware of it. Just an fyi.

Same here, just logged on after joining my guild on this alt, can’t see anything in the guild tab, nothing I type in guild chat is showing, it’s like I’m not in a guild.

Same here. Ragnaros-US

FYI they are aware.

Thanks y’all for verifying I’m not crazy. And thank you Noaa for posting that they are aware and the link. I added to that thread you posted.

2 Likes

I have the same issue, after I left from a guild yesterday, and come into a new one, I tried to use “J” to open the guild window, and it appeared as if I wasnt in any guild, but if I look at the icon of the guild tab on the menu from the bottom right corner, it shows an emblem, which means I do have one.

Hey folks,

The devs are aware of this issue and working on it now. They put in a partial fix just now which should resolve a number of these, but if you’re still having problems hold tight. It’s still on their radar.

3 Likes

thank you, I will follow for a resolution

Yea i had this problem with a toon who joined a new guild also. I dont see the guild stuff on my guild/community UI and no guild chat but is see ppl getting credit for ahieves and joining the guild plus i can look at the guild bank ect . Just on one toon which was strange

I tried an in game ticket abd got an auto response which was very disappointing

Thanks for the update. I can confirm I am still experiencing the issue.

1 Like

Happening to multiple people in my guild as well.

Problem seems to be getting worse. Now NONE of my character on two accounts have access to Guilds & Communities.

I’m having the same issue. What’s weird is that when I googled it, I found a forum post back form January 2020 that said they were working on this very same issue. But it’s suddenly come back? I wonder if someone accidentally unfixed the fix in a patch.

Unfortunately I’m still one of those people. If it helps with the troubleshooting process at all, I joined the guild three days ago, I was able to see the chat for about an hour or so–then my game lagged out, and I disconnected. I have not been able to see it since. I technically can still type there. I also cannot see the in game channel I joined during that same span, nor can I rejoin it, because the game thinks I’m already in it.