Guild and communities tab

Guild and communities tab is completely blank. I cannot see anything in guild chat. It looks like i can type in /g but nothing shows up.

Ive tried reloading, resetting chat settings, making sure the right chat is selected in settings… nothing fixes it. It only happens on one of my characters.


Same here. I left the guild and rejoined and it came back temporarily. I have disabled all add ons and it still is not present. I have also rename cache, interface, and wtf to .old. I still don’t get the chat. It is only happening on one character.


Same here.

Same thing is happening to me, only I can’t leave and rejoin the guild as it’s only happening on my Guild Master character. Guild tab looks fine for my alts. Glad to see I’m not the only one, I hope it can get fixed soon. I disabled addons and everything.

1 Like

Same here, we’ve tried reloading UI, no addons, leave and rejoin guild…nothing works for more than 20 minutes at a time

1 Like

Having this issue on a character I transferred last night, but not on my main character. Both characters are on the same server and in the same guild.

Having these same issues with social tab on this character, relatively newly made.

Also, the armory has not been updating new characters in quite a while, most posters above being transferred/new. Maybe just coincidence at this point, but curious.

I’m having the same issue with one community missing… I asked for a reinvite and its saying that I’m already part of the community. Not sure if it’s just a bug.

I’m having the same issue at this time.

Anyone manage to find a workaround for this until they fix? Worried if it’s something as long term as the broken armory.

I have blank guild screen as well. I can’t even leave the guild to re-join it. This needs to be fixed NOW!!!

1 Like

This was an issue last year too. Saw yesterday that the guild wasnt showing up, I was hoping it might fix overnight. Can see some acheivements and people logging in and out but no chat or guild tab and cant type anything into guild chat (or at least i cant see if i typed anything.

1 Like

also with the same issue with all my characters since last night

Same here. Did the old /gquit and was reinvite to the guild. Worked for a bit but the problem has returned. Again only one character of many.

1 Like

Same here. I moved to a new guild, problem still persists.

Same here just for one new character. Also have this issue on the same character.

If I /gquit and get reinvited it works until I log back out, and when I get online it’s broken again.

Several members who joined my guild tonight can’t see guild chat while long-term members of the guild at the same rank can.

1 Like

I’m also having this problem. :frowning_face:

I am having a problem with this too. I just bought the expansion day one and find out that I can’t be apart of a guild due to a community bug. Bad first impressions.

also having this problem