Crashing, freezing, and stuttering after 8.3 [Intel GPUs]

I confirm that the game works good without particles, with them the game continue crashing at the same situations.

I used to play wow daily, now I get to daily check this post. FUN!!! Sounds like maybe its worth adding my sub and giving it a go again…

I haven’t had any issues since I disabled particle density. Really happy about that, though I keep missing loot because corpses don’t sparkle anymore.

1 Like

I’m not really sure what’s worse… disabling particle density, or having the game lock up every once in awhile.

Both make the game pretty unplayable, and I hope this isn’t being looked at any less seriously now after this “fix.”


No blue post? No particle effects? Not even a “sorry?” Given w3 and all this I’m not resubscribing loooooool take my money then expect me to not be pissed? Ha good luck bliz


Hey folks,

The particle density situation is a work around. We’ve confirmed that this appears to be a driver level bug, which means that we cannot fix it and need someone else to do so, as we don’t create drivers for your graphics cards. We’re telling the GPU to do something it’s supposed to be able to do, but due to a bug with the driver’s coding, your machine is getting into a bad state. We added new particle effects with 8.3, but it’s not the core cause, just the trigger for the driver bug.

Being able to disable particle density is a work around that we put in until updated drivers/a new mac OS build are released which fix the problem so that you all can at least play. We’ve already reported the issue to intel. At this time if you are having this problem, you should disable particle density by following the steps that are recommended here. If we hear that a build of mac OS has been resolved which fixes the issue, we’ll let you know.


Really blaming at this point. We were playing fine until 8.3, so I don’t think the problem is Intel. And if this is a sorry for you Blizz im done.


Oh there’s a thread for this. Good thing I looked around huh! I never had any problems at all on an imac that has an Intel GPU. No problems. None. Got my cloak to rank 7 was supposed to raid tonight. But I won’t be there. Why? I CANT SEE ANYTHING IN THE GOD DAMN GAME EVER SINCE YOU SUDDENLY PUSHED THIS FIX I DIDNT EVEN NEED.


My game is still experiencing around 4-14fps and lag spikes even with zero particle density and lvls 1-3 graphics make no difference. Not only can I not see portals, or most important ground graphics during encounters, I can not complete certain dailies like gathering the void crystals for the corrupted void egg. My sub expires in less than 36hr and as sad as I am, I am more angry that there’s always an excuse and no fix and no resolution or compromise to all game time lost.

1 Like

My game has been crashing and freezing my computer since 8.3. 2018 MacBook Pro 2.3 i5. pretty sick of it at this point.

1 Like

Tried again today, crashed as soon as I entered an Instance. has been unplayable for a month. Are they going to do anything or not?

1 Like

You added something that broke the game (apparently the new particle density) and have looked the other way for 4 weeks, don’t blame Intel.


seems to be doing better after the patch I just dl’ed

okay so another update about my update/feedback (bc it was really to just see if it mainly froze up or not)

I can play the game now… but theres certain boss fight mechanics I can’t follow because I can’t see what’s under me or what to dodge (ex- vex how do they expect you to know where to move to if you literally can’t see when she does that purple puddle stuff and you have to keep moving to specific sides of the room… HOW???) … so I can’t do those type of bosses rofl gg blizz gg -_- mind you this is really my first time trying to do a full clear raid since they tweaked the game… so now I have to figure out what bosses to skip because I can’t do em… thats some nice raid content. and you put out a whole update saying its a bug with the gpu but wasn’t the game was fine before this patch? … kk so sounds like ur game isn’t compatible and y’all just tweaked it to make it compatible… y’all added new particle affects but you never added anything new in previous patches??? oh but the game worked though right… you guys just found out it was a “bug” after theres been reports of this same issue happening on ptr??? y’all don’t have regular Macs at the office to test on? a mess I tell you… you can play the game but I guess dying in fights due to you not being able to see the stuff you need to dodge is part of playing the game to them? is the actual issue going to be fixed anytime soon… or like are we going to have to choose to deal with a game we aren’t getting the full benefits of? (like being able to see what the heck I need to dodge in a boss fight) don’t settle for this… windows users can see what the heck they are doing… and able to follow mechanics and not get “wth is this person doing” this just feels like a big fat “l0l mactard” to the Mac users bc it feels like we are expected to settle just bc we don’t have a windows or don’t want to buy that expensive egpu… thats all im saying. y’all need to make the game work completely in every aspect because me having to leave a raid cause I can’t see what to dodge made me not want to bother with this game even more …ill give it till march cus thats when my sub runs out :slight_smile:


Thank you for the update!
I’ve been having a lot more success playing recently, feels right back to normal, hopefully it keeps on like this.
Thanks for all the hard work!

How is it a driver bug that is the problem when it worked fine until YOU changed it. Sounds to me like you guys don’t even know what you’re doing anymore. Good thing you guys fired all those people and lost all of your actually talented devs. Good going blizzard i will be unsubbing and i need to be reimbursed for my game time this month plus the 2 weeks out of the last month i couldnt play or i will be going to the FTC


At this point I say boycott review bomb and unsub clearly blizz doesn’t care about us anymore

1 Like

So wow worked before 8.3. Everything I do on my Mac besides wow 8.3 works fine. You created and TESTED a patch that broke Mac compatibility…but this is intel’s fault? Lol screw you guys.

We’re sending commands to intel that is should be able to do…well that very well may be true. Maybe it should be able to do it. But how in the heck did you not realize this during development and testing and go a different direction?

Don’t blame intel for your failure in testing and QA/QC.


As a layman, this situation appears to be very confusing.

Running MacOS 10.14.6 prior to patch 8.3, my new Mac ran WoW better than ever.

Why would you change how calls are made to the GPU for basic graphic features that worked just fine under 10.14.6 and prior operating systems?

Is this driver bug something introduced with MacOS 10.15?

If so, why are some of WoW’s basic graphic features such as particle density suddenly not working for prior operating systems (systems still supported by Blizzard)? This would make it appear the issue is with the changes made in patch 8.3, and not necessarily a driver bug introduced with MacOS 10.15.

Not to mention, this is something so basic, it should have been caught almost immediately in testing. How this got released in this condition is bewildering.

As of now, WoW is unplayable and players are left in the middle with a confusing bunch of finger pointing. Perhaps you should revert how the calls are made for these graphic features until Apple/Intel work out their differences. Because from my perspective and others, the changes in patch 8.3 are what are causing the issue because we know patch 8.2.5 did not run into this driver bug.

Otherwise, there’s nothing for players to do except unsubscribe in the meantime.


We added new particle effects with 8.3.

So you are saying you caused it then? and just blaming other things?