Consecrate is not generating threat intermittently

Strange, I generate a ‘tick’ of threat every time Consecration ticks. Have since forever.

Note: I’m not running Ret Aura and I’m just standing there.

Wonder what’s triggering the bug. :thinking:

I dont know if its bugged, but one of our pally tanks was saying it feels like the first tick doesnt go off sometimes, but odds are less a programming error, and hes placing it a bit early, so most mobs arent on it for the first tick, and have enough time to run through before the second one.

consecrate has always been a buggy skill

Wonder if it has something to do with the spell batching being nearly removed; there’s no ‘leeway’ for a mob to still get hit even after running off the puddle.

It’s bugged.

Blizzard confirmed.

The Bug is from TK dungeons.

When you die inside of a TK dungeon and you are force respawns alive outside, BOOM that triggers no threat to Consecation

You have to Exit game and Client from my experience to reset it, Its easily detected since the threat gets reflected on the threat meter when you are bugged.

Game is not unplayable.

1 Like

Icy-veins had a post about it earlier today.

Looks like they’re working on it

Still no news?!

They fixed it. They made an announcement on the fix a couple days ago methinks.

Has to be fixed, as I’m pulling 2-3 packs in Shattered Halls normal and seed of corruption spamming warlock can’t pull off aggro (that’s 5.2k dps warlock).

Make sure u use ret aura, blessing of sanctuary and holy shield I guess, along with consec. Don’t be cheap on spells, we can hold aggro against anything, throw salvation on dps if you’re bothered.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.