Consecrate is not generating threat intermittently

Fix please.

This literally makes the game unplayable.

1 Like

Righteous Fury helps a lot. It’s easy to forget to refresh it.


no its bugged

Huh. Seemed to be working fine in the group I was in last night. But if it’s bugged, yeah… Fix it.

Yeah, like I’ve been going this whole time without righteous fury.

Boy bye!

Consecrate is not generating threat intermittently
It does. It’s not an aoe taunt its quite literally a single tick of aoe damage upon cast that delivers continuous ticks of damage that produce more threat. Are you saying that it only gets threat initially and that’s it?

Honestly I have been feeling like SOMETHING is up, I have had entire packs of targets just run through consecrate before dps really does anything and I end up having to chase them down. Either somebody out there is generating a LOT of threat ( maybe healers not having threat reducing talents? ) or dps just going completely crazy without having reduction talents either. but damn it happens often.

1 Like

I started watching threat meters after reading this post as I have a prot paladin tanking for me. It appears they are getting a burst of aggro, but any other threat is being generated by either a full renewal of Cons, or other actions, no periodic threat ticks.

That sounds busted. Kinda like the druid bug I get where all my spells cost twice as much and proceed to burn the rest of my mana away for no reason. Have to shift to bear or cat (clearing the mana bar) to fix it.

1 Like

Yeah right now I’m watching their threat go up in “chunks”. Normally you’d see “Chunk, chip, chunk, chip.” in a fluid increase of threat. I’m only watching it go up in full chunks every few seconds.

Paladin is the best aoe tank already. Especially good palading holding even against my spam of seed of corruption without a mage blizzard (literally once i’ve met tank that good)

Cool. Still bugged. Being good at aoe threat doesn’t justify a bugged ability that worked correctly in the original bc and even yesterday.

What’s your point?

1 Like

Observe the race of the poster.

Wouldn’t surprise me.

I’m sure. Everyone is an idiot but you right?

That’s pretty reductive. You think I posted the suggestion because I’ve never forgotten about it?

Didn’t mean to trigger ya.

Sounds like Blizzard made another opps. Consecrate should give one big threat add on cast and then continuous low ticks of threat each time it does damage. If it is not doing this than it is bugged.

I bet they tried to do another stealth nerf to AoE farming and instead screwed up Pally threat generation. If this is true, it is really starting to make me think a group of trained monkeys could do a better job at programming.

That’s because the threat API has an incredibly low polling rate. When consecration ticks every 1 second, but your threat is only updated every 1.5 seconds, you’ll see times when there’s only one tick per update and times when there’s three ticks per update. This is only for the system that reports to your threat meter addon; it doesn’t affect the way the mobs’ actual threat table works.


It’s not bugged, they just assume just placing it on the ground gives instant aggro.

I’ve had zero issues, in dozens and dozens of dungeons.

Please let my rep grinds end.

Where do they find these people? Jesus.

No one is assuming it’s instant snap threat. I’ve also aoe tanked all the dungeons and successfully cleared Kara tanking ask well. Doesn’t matter.

The ability is bugged, and sometimes doesn’t generate threat at all. This started late yesterday. Makes sense that you didn’t have issues before. It’s also intermittent and is fixed with logging out and back in but it happens again.