8.3 Known Issues and Information

1-31-20 update: We have confirmation that this quest could be completed as of 1-30-20. Please try again.

Scouting Report: Hostile Natives does not progress

Adding community reports of quests that are like Scouting Report: Hostile Natives (in Pandaria) are broken.

That broken quest was reported in the PTR publicly in build 32861 (Jan 7), no fix was verified, and the bug escaped to Retail.

Links to PTR reports, with follow-up posts affected in Retail:

As reported in this support forum, possible fallout from this bug:


Please fix this. Thought I was doing something wrong but I’m stuck until I can finish this quest.

1 Like

While trying to complete the mini vision in Vale of the Eternal blossom, it wasn’t fair that there were no portals spawned the entire time I was in the vision. There were to many players clicking the portals that by the time I was able to find a portal I had 1% sanity left. THIS WAS UNFAIR and a very classic problem that I would have that it would have been thought about during development. Please fix portal spawn timing!

1 Like

Same issue here as well.

I’ve had the same issue, but mine will even crash when doing nothing. I’ve let it stand there just to see the result, after about 10 minutes it just dies. Only happened since patch.

The world quests are bugged, when logging in an alt that had not done the world quests and returning to the main character all world quests are reset.

Had an issue with being in a group for Horrific Visions and not receiving the correct Vessels from quests. Worked fine on my solo characters though, so I’m just kind of shorted two Vessels on my Shaman.

alt account is stuck in a different instance where there is no npc’s or portals. even entering a dungen doesnt phase back in with other players. like im offline. however its just the one character

Has anyone had problems with selling stuff on the AH and don’t get the gold for it and you pretty much lose all your items that sold pretty much. :confused:

1 Like

Vulpera can understand, but not speak, their racial language.

…And yes, please undo the 8.3 fix you applied to Glyph of Angels! <3

Unable to update game. Says it can’t identify a file. I was in and playing fine yesterday and since the patch but can no longer update.

Does anyone know which addons are causing you to not be able to turn in quests for the legendary questline? I can’t seem to figure it out and have to disable all every time I need to turn in a quest. Any leads would be super helpful so that I could just leave those specific addons off!

When doing the Reconstructing “The Curse of Stone” quest, after you loot the chest(s) you’re suppose to get gear, well, did it 4 times yesterday and got nothing but the rank update. I even 3 chested twice. I’d like a refund of my Coalescing Visions or the gear I was supposed to receive.

As far as Apple issues, I don’t know, I use a real computer.

yes I am watching my auctions sell as we speak and none of it is going in my mail. literally thousands and thousands of gold but am taking screenshots of it all, time stamped . hope they give me my gold back. I believe they can roll back accounts should they need too? cause of this auction house blunder?


1-31-20 update: We have confirmation that this quest could be completed as of 1-30-20. Please try again.

Scouting Report: Hostile Natives does not progress

For players experiencing quest blockers in Pandaria / The Jade Forest, specifically the Horde’s Scouting Report: Hostile Natives and Alliance SI:7 equivalent:

The bug was regressed on 1-17-20 in the new PTR build The quest still cannot be completed.

Since this is the same build now on Retail, the assumption is the bug still exists there as well.


Sun Prophet Epaphos (Uldum Rare) will continuously cast “Blinding Radiance” until someone is hit by the spell.

Inside the vision the orb operation used to reset sanity, worked initially then on my next 2 attempts failed these attempts were seperate attempts as i understand you can use it 3 times in one vision.

This also happened to me, told blizzard customer support and they said it wasn’t an “official bug” so pretty much “sucks for you”

Anyways +1

1 Like

This happened to me as well. Any update on if we’re getting refunded our vessel or not?

I Cannot enter the Ulduar raid. I Don’t know anyone else with this problem but the instance portal to the raid is broken.