Mage invisible screen effect missing? Cannot progress through missions like "Scouting Report: Hostile Natives..."

While playing my character Alarn on Uldaman, my mage, I can no longer see the fullscreen effects from spells like invisible, and the scouting mission, “Scouting Report: Hostile Natives,” where the Hozan NPC tells his story does not start. My character teleports, but I do not change into the NPC to start the quest. I have deleted WTF file, cache file, repaired the game, tried playing again to see if it fixed, then I tried uninstalling and reinstalling the game. I can no longer progress through certain quests like this one, and many of them are tied to gate progress, essentially breaking the game.

I’ve also tried /reload ui, and getting rid of all my quests and re-acquiring the quest in question. Nothing is working.

I also do NOT have any addons right now.

There are actually 3 folders, I’m not seeing interface in your list.

I’d give a proper reset UI another go, and you may also want to reboot your system. Reinstalling, depending on how it is done, actually doesn’t necessarily do the same job, nor does /reload.

1 Like

Is this part effective after the reinstallation or before? I noticed you mentioned the WTF and Cache folders, but leaving the Interface folder basically makes that null.

1 Like

before installation, right after the new patch. I reinstalled the game AFTER the same troubleshooting steps on how to reset userinterface. Also, none of my characters who are in lv range of that quest can get it started, and on all of my 4 mages, invisible does not show the fullscreen effect.

If you are certain those steps were completed fully, I’d pop in a Tech ticket, see if we see the same thing you do.

1 Like

Yeah already done. I copy-pasted the tech ticket here just incase anyone else is either having the same issues of certain NPC missions not progressing or all their mages also not showing the fullscreen effects for invisible etc.

I tried doing the same quest on my 82 orc warrior, and he can’t turn into the hozan to complete the quest either, and again, 3 other mages’ invisible do not show the proper “Lord of the Rings” effect when they phase out into invisible.

And yes, I did delete or rename every folder, I just didn’t list the third one. Interface, WTF, and Cache. It was the first thing I did when /reload UI and resetting the game, and getting rid of all my quests didn’t pan out. And I reinstalled the game after all of that.

It would probably be a good idea to also make a thread in the Bug Reports forum, as it is likelier where you will find other players with the same issue.

It also has the benefit of putting it on QA’s radar for reproduction and eventual correction, if they discover anything.

1 Like

I intend to.


I am in the middle of attempting a second reinstall, this time I made sure I scoured the file systems that uninstall leaves behind sometimes. It turns out the World of Warcraft folder is left behind after the install, and even if it’s empty, I deleted it anyway just to cover my bases. Nothing was left in documents, so nothing needed to be deleted there. Anyway, after this attempt, I could try to delete the registry files, but because I don’t know what I would be looking for, I will wait for the tech people to email me. In the meantime, hopefully my latest reinstall will work. I will keep you guys posted.

Update: Still experiencing the same bugs even after the second, more thorough reinstall.

1 Like

same here, I thought it was just an better visual upgrade till I see your post:/ only character changes.

The quest Scouting Report: Hostile Natives is broken. The bug was confirmed in the PTR, and a post link to other community reports added to the 8.3 Known Issues thread.

The related mage effects problems could be a symptom of the bug, as the broken quest cannot be passed by different classes.

Regarding the blocked quest issues in this thread, we have confirmation that Scouting Report: Hostile Natives could be completed as of 1-30-20. Please try again.

1 Like