8.2 Known Issues and Information


(Kaivax) #1

The Rise of Azshara content update is now live. Please read on for a list of known issues that we’re working on, and further information about the update.

As always, Blizzard Customer Support is here for you! If you don’t see your issue in the list below, Get help here 24 hours a day, 7 days a week.

8.2 KNOWN ISSUES
Updated June 25, 2019

Classes

  • Death Knight
    • Bursting Sores’ damage increase has no interaction with Necrotic Wound.
    • Dancing Rune Weapon can fail to mirror the player’s spells.
    • Runic Power isn’t refunded at 80% of its cost when it misses or parries.
  • Shaman
    • Stormstrike (17364) doesn’t refund 80% of its Maelstrom cost when it misses or parries.

Dungeons and Raids

  • The Mythic Keystone Season 3 difficulty increase is unintentionally displayed before Season 3 begins.
  • Battle of Dazar’alor
    • Lady Jaina Proudmoore
      • If the main threat target gains Frozen Solid, Jaina can cast Ice Shard at a random target instead of switching to her secondary threat target.

Pet Battles

  • Bloodseeker and Deeptide Fingerling do not have a bubble surrounding them when summoned.
  • Stratholme
    • When players lose to the Wandering Phantasm, it will respawn where it initially spawned.
    • The Plagued Critters do not have a marker on the minimap.

Player versus Player

  • Gaining Conquest Points that exceed the current quest’s maximum does not overflow into the next quest if that quest is available.
  • Ashran
    • Level 110 players that queue into Ashran are not placed in the 110-119 bracket.
    • Player spell effects on Kronus and Fangraal appear extremely large.

Quests

  • The quest completion marker is missing for "Trouble in Gnomeregan".
  • “Give 'Em Shell” enemies do not have quest objective highlighting.

System

  • Switching from DirectX 12 to DirectX 11 may crash your GPU.

User Interface

  • When you’re dead, mounts are unintentionally highlighted on your action bars as if they can be used.

For those just returning or who otherwise need to be caught up we have guides for both new and returning players.

New Player’s Guide

Returning Player’s Guide

As with any update it is important to make sure that if you use addons that they have been updated. It may be a good idea to reset your UI to default to make sure that the old files aren’t causing any issues.

Resetting your User Interface

Helpful links for various tech issues:


Battle for Azeroth 8.2 - Info & Known Issues
Season 3 Already began!? +14 now a +17
(Kaivax) pinned #2

#3

I can’t upgrade my Benthic pants on my DK. Says Item Can Not be Upgraded.
EDIT 6-26-19: It did eventually upgrade later last night.


#4

I have an issue with Azerite Madness in Vol’Dun… I completed the quest and it came right back up like I can do it again… I noticed it with the Azerite Empowerment WQ in Drustvar to kill Sister Hilga is doing it as well… Being able to be completed multiple times… Is this going to be addressed? Because I believe this can be exploited by those who see it as a way to do a WQ multiple times to acquire additional rep and rewards from these two world quests. I did the siter Hilga twice more or less due to the fact I thought I did not actually get credit for it due to phasing between that and what appeared to be a separate instance of Azerite Madness being up in the same location when it phases you.


#5

While in a 20 man raid group it’s not allowing us to que into Heroic battlefront?

Edit -

Second issue, using Worldvein Resonance is taking me out of stealth randomly causing quite a bit of an issue.


#6

As Emerston said, we can’t que for Heroic Warfronts. please actually answer us it’s sad how lacking communication is.


#7

All the world quest are messed up, I’ve been trying to do Azerite Madness for the past hour and anytime the percentage gets close to 40% it resets and I have to start all over, and my boy friend has been having the same problem as well, along with many people around this area.


#8

I got the quest for the heroic Warfront. Signed up with 415+ players who have completed the normal assault, experienced with the warfront, received the quest ‘the heroic warfront: the battle of Stromgarde’, changed dungeon and raid to heroic. However, there was no indication of allowing us (or me as the leader of the group) to queue up for the heroic warfront for Stromgarde.


#9

On Mythic Mekkatorque, there is actually a cast of World Enlarger that goes off without shrinking people, which leaves us with an extra set of bots, we get 6 bots up prior to entering P2.


#10

Inflatable Mount Shoes was slotted on my mounts and vanished after a re-log.


(Sniperorc) #11

Confirmed. Happened to me too.

Editing: The equipment vanished from the slot, but I still have the buff when I’m mounted. So I suspect it’s a UI issue? I’ll check again after a UI reset.


#12

Completed quest for rank 2 zin’anthid before purchasing rank 1 from the profession trainer (why’s this even a thing? we can collect the herb w/o rank 1).

Now I cannot get rank 2 (and obviously 3, because of that).

Huge bug and really dumped on my plan of herbing early.


#13

The Anglers’ Water Striders does not work on the sky golem mount


(Marniia) #14

This is from the Blizz news feed regarding mount equipment:

Note that mounts do not benefit from mount equipment in battlegrounds or Arenas and that some do not benefit from mount equipment at all such as the Sky Golem.


#15

I had the same thing happen. Tried to grab another one off my alt but it won’t let me equip it. Says I already have one of those equipped but it is not in the slot and my mount does not water walk.


(Paladuck) #17

they did answer it on twitter - it is a known bug, even though it isnt listed here, and being worked on.


#18

They aren’t supposed to work on that mount


#19

I started the Meka missions and there is one called “Building excavation platform” or something, a mission where i need some pieces and specially an Energy Cell, i used this last one but it didn’t take effect over mission objectives, i can not abandon or restart mission, what can i do?!?


#20

I just started a raid group for the world pvp event on Naz and midway through while we were dominating I was phased to a different realm that was losing and I lost. I know the group I had started won…wondering if I can get the points for the phasing messing me up?


#21

I had this same issue yesterday in Drustvar. Also there were two Quest One for the elementals and one for the sister that overlapped.