WoL Campaign Achievement (Hard) Not Updating

Hello, I can’t seem to figure out how to resolve this issue. Back in 2010, I managed to complete 20/25 of the missions on Hard difficulty. I achieved 4 out of 5 milestone achievements along the way (e.g., 5/25, 10/25, 15/25, 20/25).

I returned to SC2 about a month ago, and I noticed that the achievement progress was reset to 0/25 completed.

Wanting to complete the achievement once and for all, I completed a few missions on Hard difficulty again, but the progress bar is not giving me credit; it remains at 0/25 completed. I’ve tried the following:

  • I already had a save where I beat it on Brutal. I loaded up the Mission Archives and played the first 3 missions on Hard. No achievement progress reflected.
  • I started a brand new campaign on Hard and beat the first three missions. Still no achievement progress reflected.

I even spoke to a Blizzard GM who said the following:

This usually only happens if you are not connected online properly, as you need to be online to load and trigger achievements.

If you are offline the game will still keep a local save to track your Campaign progress, but achievements will only trigger if you are online.

Sadly we can not assist with granting credit for achievements, you would need to try and meet the criteria for these again.

It’s highly unlikely that I’m experiencing connection issues because I have been getting 10th Anniversary achievements here and there while I was working on the “Hurry Up, It’s Raid Night” achievement while I was waiting for a response to this issue. I’m not sure what to do at this point.

Should I just continue playing the campaign where I started on Hard and hope that I will get the achievement when I beat 25 missions even though the achievement progress continues to show 0/25 completed?

Maybe I’ll beat the last 5 missions on Hard difficulty through the Mission Archive and see if I get the achievement then. I just want to make sure that I will get the achievement because this is 1 of 2 of the remaining achievements I need in order to 100% WoL.

To finish, this is the last communication I received from a Blizzard GM:

I am sorry for the inconvenience this may cause you. If you are connected online and still not getting the achievement could be some problem in the game. Unfortunately, we do not have a way to verify this from here, since our support for Starcraft is very limited. In this case, what I suggest you is to report in the forums to be investigated. I have also reported from here to help with the case.

Any help is appreciated. Thank you for your time.

Hey there,

There’s one thing that I’d recommend trying. Delete the Blizzard cache folder to clear out the Starcraft II profile/achievement cache and then re-launch the game so it will be recreated.

If that doesn’t do it then I’d recommend reporting it as a bug over on #bug-report , since it should definitely be giving you new achievement credit for completing those missions on Hard.

Thank you. I will try this as soon as I can and provide an update in this thread.

UPDATE: I have a follow-up question: If I beat the campaign on Brutal difficulty, was I supposed to get credit for completing it on Hard at the same time? If so, then this definitely is a bug because I started a new campaign on Brutal and completed every mission (received Kerrigan portrait).

Hey again,

As far as I’m aware the achievements do not automatically credit the lower difficulty achievements if you beat it on Brutal. Since each mission is tuned differently for each difficulty you would have to play each mission more than once to get the Normal / Hard / Brutal achievements.

Hi, I have the same issue, and it is not a problem with local files. I had this problem on an old computer, and still have it after a clean install on my new computer (same account)

Well, that answers that. Apsis and I are experiencing the exact same issue, which Apsis posted in the Bug Report forum already. I’d like to add that I started a new campaign on Hard difficulty but the progress bar is still showing 0/25.

That’s good to know, thanks supersaiyoon and Apsis!

Hopefully with the two bug reports our Quality Assurance team can investigate further and determine if there is something amiss with the Hard mode achievements.