Starcraft 2 Crashes everytime on startup


#1

Whenever i load in the game, it goes into seconds of black screen and then an unexpected error occurs. This is all i could’ve done:

  • Reset ingame settings
  • Reinstall SC2 completely
  • Scan and fix SC2
  • Uninstalled Destiny 2 ( Because i recently installed it and thought it was the cause )
  • Updated to latest Version for my Graphic Card
  • Closed down some apps running in background with Task Manager
  • Removed some battlenet files in App Data as that helped for some people
  • Runned both Battlenet and SC2 as administrator
  • Disabled Windows Firewall
  • Removed SC2 from Discord’s Game Activity

Code: 84486BE0-BBEF-4971-ADB8-2E248DF80BDC


#2

That’s some pretty good troubleshooting you’ve performed!

If you don’t mind me asking, do you play any other games at the moment - and if so, are those running okay, failing to run, or running with degraded performance?

Was the driver update performed over the previous install, or was the older version uninstalled first? If the former, try resetting your driver to default settings.


#3

I only play broodwar for now, but it doesn’t fall into the same problem, same thing for the rest of the games i used to play, they all run normally.

I’ll try resetting my driver, and the install was previous i think.

(EDIT)
Nope, problem still occurs


#4

Hey XeliosRanso,

Thanks for providing all of that info and the crash code. I looked up the crash and it does look like a graphics related crash.

I noticed that the 32-bit client is being launched instead of the 64-bit. Can you try switching to the 64-bit client and see if that will launch?

In the Blizzard app click the Blizzard logo in the top left and go to Settings -> Game Settings -> Find Starcraft 2 and uncheck the “Launch 32-bit client” box to disable it.

If that is still crashing lets try resetting the Nvidia control panel settings to default next.


#5

Oh my gosh, i haven’t thought of that before! i’ll see if it works!

(EDIT)
Well i followed your instructions for the 32-bit client, but it was allready unchecked, and i tried resetting the control panel settings but both of them hasn’t work, so i tried restarting, and nope.


#6

Hey XeliosRanso,

Can we try putting SC2 in windowed mode to see if there’s any change?

  1. Open the Blizzard app
  2. Click on the blue Blizzard logo
  3. Go to Settings
  4. Go to Game Settings
  5. Click Additional command line arguments for SC2
  6. Type -Displaymode 0

#7

I typed it in and clicked play, it was in windows mode, but the result still has the same effect, i’ll try to restart.

(Edit)
Nope the restart hasn’t functioned either.


#8

In this case, it would be best to open a support ticket and include your MSinfo so we can take get this further investigated.


#9

It is a graphics setting that you graphics driver is changing that the game is no longer recognizing. Go into the blizzard launcher > settings > game settings than scroll down to Starcraft2 and click the “Reset In-Game Options”. This will revert the game video options to default and allow you to load in. I tested this several times by allowing Nividia Geforce experience to optimize and SC2 would simply crash at load up with that same message and when set back to default I am able to load in. Also be sure to uncheck 32 bit for windows 10


Client wont launch since Win10 1903 update
Martoq's thread
#11

This worked for me! Thanks!


#12

“Reset In-Game Options” worked for me…


#13

This worked for me! Thanks! Had the exact same problem, just didnt do all that troubleshooting, just followed this advice and changed my settings back to extreme and back in business!


#14

How? I did what he said and the problem still occurs.

(EDIT and possible cause)
Ok i just figured out what really happend, my SC2 doesn’t work with windows 8 for some stupid reason, but as i use my new gaming laptop that has simular specs and windows 10, it works.

Apparently that means i have to upgrade my OS and then tweak my graphics a bit and it’ll be working fast!


split this topic #15

A post was split to a new topic: CPLJOHN Thread (Crashing)


split this topic #16

A post was split to a new topic: Spliffmaker Crashing Thread


#17

hello, i have the same exact problem! if you could, please check my error code and see whats the problem, thanks! :smiley:

F85607B4-768E-45B0-B537-0665BA4A97F4
new one:
F5DC2031-B80D-4E92-8944-234F615872F3


#18

Hi, I’m having the same issue. I’ve tried:

Reinstalling
Opening in 64bit/32bit
Putting SC2 in windowed mode using -Displaymode 0
Scan and repair
“Reset In-Game Options”
Restarting computer

Yesterday there was a post on how to fix the Asia server, by deleting the Base75689 Folder in StarCraft II / Versions. That made me able to play the Asia server!

However, I am still unable to play NA (my main server) and EU.

Error Code: 2127D583-BBE4-4E9F-B692-C529EBDDF9E7

I am playing on a Mac with Bootcamped windows 10.
Thanks.

Edit: I am now unable to play on the Asia server. Perhaps I have to keep deleting the base Folder to play there.


#19

I upgraded my OS and it seems that starcraft is playable again, it seems that the windows update might’ve rendered it unplayable on windows 8 or i don’t know.

What matters now is i can play!


#20

So upgrade OS is the only way?


#21

not technically. i have windows 8.1 and i have no issues. i could try to help you.