Client wont launch since Win10 1903 update


#1

Client will “blink” or “breath” on launch to black screen back to desktop a few times until getting the following error message:

Graphics device is not available at this time. Please try starting StarCraft II again, or restarting your machine. If problem presets, for more information consult our support website at http://blizzard.com/support

This started after updating Windows 10 Pro to the 1903 update.

Troubleshooting steps taken:

  • Force launch in 32bit.
  • Scan and repair.
  • Uninstall and reinstall.
  • Check for system updates and graphics drivers.
  • Restarting the machine.

Other info:

  • Current GeForce Game Ready Driver - 431.60.
  • Dxdag on request.

#2

It wouldn’t do any harm to use Display Driver Uninstaller and then perform a fresh install of the graphics driver - even if it’s the same driver version.

You can download the driver installer and place it on your Desktop prior to running DDU, which will make it easier & more convenient to find.


#3

If the problem is still happening after what Sarno suggested, please update the thread with a DxDiag so we may better assist you. Once the file is collected, post it on pastebin and drop a link here. You can use the </> code button so the forums doesn’t block the link.

Example:
pastebin.com/abc123


#4

I am having the same issue. I opened a ticket yesterday, still waiting.


#5

Since Blizzard Support is asleep at the wheel… Simply revert to previous build of Windows 10 to solve this issue.


#6

#7

“Reset In-Game Options” worked for me!


#8

Yup! Worked for me too!