Starcraft 2 Audio Speakers Setup ( Windows 10 )


#1

I can’t select the Speakers Setup in the audio Setting. It’s locked on 7.1 and i can’t do nothing about it.
The game says that the setup is the one selected by the windows control panel, but this isn’t true.

I have no device 7.1 ( or 5.1 ).
In the control panel the settings are stereo for both speakers and headphone.
In the Realteck audio panel the settings are stereo for both speakers and headphone.

What can i do? The sound of the game is terrible…music is very loud also if I set it at 30% and voices are very low also if I set it at 100%.

It will be so simple if I could change the audio setup setting…


#2

Hey there Sparviero,

I’d start off by disabling anything listed by Windows other than the desired playback device. Once that’s done lets reset the game settings and see how it goes!


#3

Hello! Thank you for the answer…but the playback device was already the only one enable. I also checked a setting about “virtual surround sound”, but it was already disable. I enabled it and disabled it just in case, but nothing happens.


#4

if you have a different device, you could use that if you are using either hdmi or displayport from your graphics card to your monitor. i for example use nvidia high definition audio which is a sound chip present on my sound card. that depends of course on what graphics card you have but, any nvidia card from 600 series have nvidia high definition audio on desktops. laptops use a different chip.


#5

Lets try this. Go into Playback in the Sound menu, right click on the speakers, then select “Configure Speakers” - In this new menu select “Stereo” and click next, Front left and right then next, then finish!

Once that’s done, try restarting the game and see if there are any changes.


split this topic #6

9 posts were split to a new topic: StarCraft II Audio Muffled/Broken on Latest Windows 10 Update


closed #15