StarCraft II Audio Muffled/Broken on Latest Windows 10 Update

Exactly the same problem here. In Windows 10 settings it’s set on Stereo but in SC2 it’s on 7.1 and I can’t change it.

1 Like

which is technically stereo.

Same problem, bump. My sound settings are stereo but SC2 says 7.1

which is possibly better than stereo. you get surround which is better than stereo.

Same issue for me, tried all of the suggested fixes. Nothing have worked yet.

why do you even want to go back from surround to stereo?

Thx Blizzard for the new patch…
My audio settings says its 7.1 and i cant change it. Nothing changed in windows, windows sound settings are stereo.
The SC2 in game sound is terrible. Pls fix it.

Ok, sorry Blizzard!
This is a Windows issue.

www[dot]tomshardware[dot]com/news/windows-10-audio-not-working-microsoft-update,40395[dot]html

Running into the same problem. Microsoft acknowledges that KB4515384 update is the culprit. Unfortunately for me, I can’t remove this update (it may have to do with my system being in the Release Preview ring, I’m already running Windows 10 v1909 (Fall 2019) Build 18363.356).

In Microsoft’s own KB notes on their support page, they provide a work-around to open the settings in the game itself and disable multi-channel (surround) sound, however SC2 is set to be locked to the settings in Windows.

While Microsoft is easily at fault for this update bug, why prevent us from setting game audio the way we want it in the game itself?

Now we are essentially left with a few options:

  1. Blizzard would need to patch the game up so that the end-user can select their own audio settings in the game, independant of the settings in Windows (This is the way it should be in the first place! Let me control my own gaming experience!)
  2. Wait for Microsoft to release their own patch solution (currently planned for end of September 2019 as per KB support notes).
  3. Uninstall KB4515384, which may not be an option for everyone, such as me.

You can see Microsoft’s known issues for KB4515384 here, about half-way down the page: support[dot]microsoft[dot]com/en-us/help/4515384

Thanks for sharing the information, everyone! I moved this over to a new thread as this a different issue than the initial report. Plus, the new title may help draw more attention :slight_smile:

We are seeing audio muffled/broken reports throughout our games for the latest Windows update, here’s microsoft’s page for the latest update. An update later this month (September 2019) has already been planned by Microsoft to address this issue.

You can check if you’re on this update through the Update History or by checking the Windows version. Press Windows Key + R, type in winver, you’ll see the Build 18362.356.

In the mean time, it may help to try playing around with a few settings in-game and through the Sound settings. If you do have third party audio applications, it may help to adjust the multichannel audio there as well. Though it’s not the same, I’ve personally found that setting the Spatial Sound settings to Windows Sonic for Headphones helped a bit depending on the game.

As for additional settings for audio setting adjustments to be added to the game, I can’t say for certain this would be something our team would be able to implement before the patch comes out. Though, these settings may be great to have in the future to make the game more customizable for the individual. The feedback for this would be better discussed on our General Discussion forums, since this is the Technical Support forums, it may be easily missed here by our developers and game designers.

1 Like

KB4517211 was just released to release preview testing ring. I have already tested it myself and the good news is that it has fixed the audio issue! I now correctly see “stereo” as my speaker setup and since I have an actual 2.1 speaker setup, the audio now sounds like it should. Hopefully it shouldn’t be too much longer until Microsoft releases the update to everyone!

1 Like

Highlighting this here! The KB4517211 update calls out the muffled/broken audio should be fixed with the latest update!

Hey guys - now it is March 2020 and I have exactly the same issue. It can’t be another windows patch, can it?
It is on a completely new computer build, nvidia GTS 2070S and a gigabyte sttrix x570 e-gamer mobo.
I tried all the common suggested steps already…

And by the way. It works perfectly in D3

I finally figured it out, if you only have 2 speakers (Laptop) or headphones

1-Go to Control Panel\Hardware and Sound
2-Then select Sound
3-Look out for your speakers, make sure you have it as default device & default communication device (You can check with right click)
4-Right click and “Configure Speakers”
5-Select 7.1 Surround, click next
6-In optional speakers, identify the working speakers by testing them in the right side diagram, click next
7-In Full Range Speakers, Disable Front Left and right and sorround speakers, click next
8- In “Sound” Right click your speaker and make sure “Windows Sonic for headphones” is disabled in spatial sound tab, click apply and then ok.
9-Finish, and restart SCII

It worked for me on a MSI Dominator Pro gt62vr 7re

Using Nahimic 2 and Realtek last drivers (april 2020)

[Edited by Moderator] This thread has been inactive for some time. Please be mindful of resurrecting older threads. A new or more recent thread can be created to continue the discussion. Locking this thread.

1 Like