SC2 won't start


#1

Game immediately crashes whenever I try to play. I have tried the scan and repair feature. I have also reinstalled sc2 but that didn’t help.

This is the code I got the last time I tried to start sc2: FE16F9C7-3320-46A1-8D88-EF62373C8B03


#2

They might ask you to include your MSInfo and or DxDiag for troubleshooting, had them request for similar problem in another thread.


#3

ive got the same problem C4C2E669-1872-4B48-AB25-991BC372CD31


#4

Howdy WhackMaster!

This occurrence error appears to be an ACCESS_VIOLATION (0xC0000005) the game is attempting to interact with system resources but something is going wrong.

I would recommend the following steps to see if we can narrow this down!

  1. Make sure Windows and your Intel display drivers are fully up to date!

  2. Close down all background applications to help troubleshoot any third party conflicts that may be occurring following the steps for your Operating System Here.

  3. Reset the game settings back to default following the steps Here.

Retest!

If the issue continues, please post up your Dxdiag for us to review. Copy the dxdiag contents into your reply, highlight the text then select the code block icon </>. This action will help us review the information faster.

Thank you!


#5

Anx,

Your issue is in the same ballpark so for this case, I’ll allow you to stay in the thread but instead of updating Intel drivers you would update Nvidia drivers Here. If the issue continues to get us a Dxdiag.

Thank you!


#6

Same issue, “Unexpected fatal error”

39F43159-3694-4A74-939E-0257DC906F59


#7

I’m having similar problems. When I try to start the game it tells me to restart my machine or reopen the game.


#8

I can’t seem to connect. It tells me I have to put in my password and when I do, I still can’t log in.


#9

Same things is happening to me, put in username and password, nothing happens. Game wont launch!!


#10

I get graphics not enabled. This new update is cooked. Fix the issue Blizzard.

Can login into the other games so I know its not the graphics.

Drivers are all up to date.


#11

Same problem
Im also using windows 7


#13

Yep, new update kill the game.


#14

Thank you all for your reports! We’ve been seeing some success with resetting the WMI Repository. A new admin account will reset the WMI repository as well.

We’re looking into reports for this to, if you can let us know if resetting the WMI repository or New Admin helps with the StarCraft II crashing issues.


#15

i tried it (that with new admin acc) and it didnt work, i can post myDxdiag if you want


#16

I created a new admin account and can run the game from there but my primary account keeps getting an error saying my “graphics device isn’t available.” Every other game works just fine and Nvidia Experience detects StarCraft without issue.


#17

you created a big problemo here with the update such that game can’t be used. U guys better fix it not give us stupid chores to do. Sorry for the bluntness, but this is on you, not your players.


#18

I fixed the issue by going into options on the launcher then to game options and resetting in-game options (blue button at the bottom). I don’t have any idea why they needed resetting to begin with but this last update was definitely screwy.


#19

Was having these same issues and this reset fixed it.


#20

Admin account working, main account not.

Just updated video drivers to 436.02 08/20/2019. Nothing I do will let me log in. I can enter user name and password, but the spiny thing just keeps spinning and the log in buttons do not appear (on rare occasions they have appeared but don’t work). I have tried every trick mentioned mentioned here or in any other thread I can find but that made things worse as now I can’t play offline either (Authorization Required). Still waiting on a fix.


#21

@TOS, on the main Windows account does resetting the WMI fix the issue?