SC2 "Temporary Battle Net Outage" strikes again

Hello everyone,
apparently this issue is popping out again.

I hadn’t login in a long time, and today I just reinstalled the game, completed the authentication (with correct login credentials and 2FA via battle net android app) on the EU server and I was greeted by the “There is a temporary outage of battle net service” error message.

I don’t think I have a networking issue, because the BattleNet application doesn’t raise any error, and the game performs all the login steps correctly.

Anybody else is suffering from the same issue?


Having same issue. Reinstalled today and am unable to connect to EU where all my progress was.
If I swap region in the launcher to US I don’t have the issue.

1 Like

Having the same issue on EU as well.

im in the same boat. I can easily connect to US but not EU where all my progress is.

My friend can connect super easy while i get the error of a “temporary outage”

Yes, same issue on EU server

same here. US works, EU not

same here, i did a lot of things to fix the problem , no one of it works , its been 2 days now , able to login in na and asia not in eu , my server.

Same problem here - NA/Asia working EU not after some months of not playing sc2. Tried reinstalling, fixing, removing cache, turning off firewall nothing works. Also I don’t have PTR application in sc2 directory (or anywhere else) so it’s not that problem.

Same here, can´t play on EU reinstalled, tried Beta launcher nothing works.

Can confirm - I’ve tried to login for a couple of days to EU, with the “There is a temporary outage of battle net service” -error. Can login to Asia and N/A, which tells me it should not be any windows firewall issue.

Current SC2 version, no idea what was the last version I tried to log on with, as it has been a while. Another, more recently used, account was able to login, so apparently the problem is due to not being logged on in a while?

Same issue for me as well.
I don’t have PTR installed
Switching to beta launcher did not help
Uninstall sc2/ reinstall sc2 did not help
I can login to US and Asia but not to EU
Any update would be appreciated!


Yup. Happened to me too. Still an issue 24 hours later

1 Like

Hey all,

We’re aware of this issue impacting the EU region and our engineers are working on getting it resolved.

Once we know more we will update this thread.


i have the same issue, funny thing, i set up my rig for the first time in 9 months, so it took me some time, a re-install and a deep dive into my router and firewall before it struck me that it might be a more general problem.
good thing you are on it, information on the face of the bnet app would be helpful when these things happen :slight_smile:

1 Like

Same issue here, haven’t played in years and installed today.

Telling me there is an outage for europe, USA etc still work.

1 Like

Amazing that a post about EU servers is getting replies from support in the US forum, but not on the EU forum…

The problem seems to have been resolved for me

Changes were made, services were restarted, and this issue should be resolved now. Please try logging into EU region again and let us know if any errors persist.


Works fine now, thanks @jambrix !
Shouldn’t have wasted almost 3h today changing all my router and firewall settings randomly lol


Login successful, thank you! Only thing: game marks only Zerg campaign as completed in US region and only protoss campaign completed in EU region, but it’s a minor thing. TY!