SC2 Crashing on MacOS Catalina with Radeon Graphics

after a somewhat tweaking in beta mode, seems that ULTRA resolution is the problem. Switching to High does the job (Metal or OpenGL 4.1)

==> BLIZZARD, you now know what to do, seems to be buffers management that sux (ellesmere or what ?). Is 36 the correct value you use for buffer allocation onto RX580 ?

1 Like

Me too, this especially happens to me during coop games. I would be playing protoss, and the moment the twilight council completes, Crashes. It happens in almost all my games now! I can play like 10 mins max before it crashes. Then somedays, it decides to let me play for like an hour, before it turns on me again!

Same issue here. Was playing SC2 coop (EU) and got a similar kernel panic:

`panic(cpu 0 caller 0xffffff8018a62e0a): Kernel trap at 0xffffff7f9ac6b961, type 14=page fault, registers:\nCR0: 0x000000008001003b, CR2: 0xffffff848efc5014, CR3: 0x000000002f77c000, CR4: 0x00000000003626e0\nRAX: 0x0000000000000385, RBX: 0x0000000000000385, RCX: 0xffffff98e391bcc4, RDX: 0x000000000000af20\nRSP: 0xffffff98e391bc78, RBP: 0xffffff98e391bc80, RSI: 0xffffff848efc4200, RDI: 0x0000000000000385\nR8:  0x0000000000000001, R9:  0x0000000000000003, R10: 0x0000000000000000, R11: 0x0000000000000000\nR12: 0xffffff98e391bdd8, R13: 0xffffff98c2cdc330, R14: 0xffffff848efc4200, R15: 0xffffff98e391bde4\nRFL: 0x0000000000010287, RIP: 0xffffff7f9ac6b961, CS:  0x0000000000000008, SS:  0x0000000000000010\nFault CR2: 0xffffff848efc5014, Error code: 0x0000000000000000, Fault CPU: 0x0, PL: 0, VF: 1\n\nBacktrace (CPU 0), Frame : Return Address\n0xffffff98e391b6d0 : 0xffffff8018939a3b \n0xffffff98e391b720 : 0xffffff8018a70fe5 \n0xffffff98e391b760 : 0xffffff8018a62a5e \n0xffffff98e391b7b0 : 0xffffff80188e0a40 \n0xffffff98e391b7d0 : 0xffffff8018939127 \n0xffffff98e391b8d0 : 0xffffff801893950b \n0xffffff98e391b920 : 0xffffff80190d17f9 \n0xffffff98e391b990 : 0xffffff8018a62e0a \n0xffffff98e391bb10 : 0xffffff8018a62b08 \n0xffffff98e391bb60 : 0xffffff80188e0a40 \n0xffffff98e391bb80 : 0xffffff7f9ac6b961 \n0xffffff98e391bc80 : 0xffffff7f9ac09d09 \n0xffffff98e391bcf0 : 0xffffff7f9ac09ae3 \n0xffffff98e391bd80 : 0xffffff7f9ac05218 \n0xffffff98e391bdc0 : 0xffffff7f9ac0934a \n0xffffff98e391be10 : 0xffffff7f9ab2b877 \n0xffffff98e391be60 : 0xffffff7f9ab39438 \n0xffffff98e391bea0 : 0xffffff7f9ab38bf8 \n0xffffff98e391bee0 : 0xffffff80190401bd \n0xffffff98e391bf30 : 0xffffff801903eb02 \n0xffffff98e391bf70 : 0xffffff801903e08c \n0xffffff98e391bfa0 : 0xffffff80188e013e \n      Kernel Extensions in backtrace:\n         com.apple.iokit.IOAcceleratorFamily2(438.2.7)[72B8A0B5-E12C-3764-9187-0AC0E93416F9]@0xffffff7f9ab27000->0xffffff7f9abeafff\n            dependency: com.apple.driver.AppleMobileFileIntegrity(1.0.5)[180FC5AB-0E47-35BC-91DF-609EBE8ED4A5]@0xffffff7f99d33000\n            dependency: com.apple.iokit.IOPCIFamily(2.9)[AA7C7A4F-9F5D-3533-9E78-177C3B6A72BF]@0xffffff7f9932f000\n            dependency: com.apple.iokit.IOSurface(269.6)[39DC4195-B168-3895-ACD5-E731581855F8]@0xffffff7f9aaf6000\n            dependency: com.apple.iokit.IOGraphicsFamily(568)[247C211E-C250-351C-BCE2-4DB9D3003E10]@0xffffff7f998ca000\n            dependency: com.apple.iokit.IOReportFamily(47)[2CCA7DD3-C33F-3CA4-A213-BC83D3D997B0]@0xffffff7f996dc000\n         com.apple.kext.AMDRadeonX5000(3.0.2)[04DFA76B-06BE-3483-9EB4-E7779C7E1564]@0xffffff7f9abff000->0xffffff7f9ae04fff\n            dependency: com.apple.iokit.IOPCIFamily(2.9)[AA7C7A4F-9F5D-3533-9E78-177C3B6A72BF]@0xffffff7f9932f000\n            dependency: com.apple.iokit.IOSurface(269.6)[39DC4195-B168-3895-ACD5-E731581855F8]@0xffffff7f9aaf6000\n            dependency: com.apple.iokit.IOGraphicsFamily(568)[247C211E-C250-351C-BCE2-4DB9D3003E10]@0xffffff7f998ca000\n            dependency: com.apple.iokit.IOAcceleratorFamily2(438.2.7)[72B8A0B5-E12C-3764-9187-0AC0E93416F9]@0xffffff7f9ab27000\n\nBSD process name corresponding to current thread: kernel_task\n\nMac OS version:\n19B88\n\nKernel version:\nDarwin Kernel Version 19.0.0: Thu Oct 17 16:17:15 PDT 2019; root:xnu-6153.41.3~29\/RELEASE_X86_64\nKernel UUID: 7503CD47-851F-321E-8747-50DB4299165F\nKernel slide:     0x0000000018600000\nKernel text base: 0xffffff8018800000\n__HIB  text base: 0xffffff8018700000\nSystem model name: iMac19,1 (Mac-AA95B1DDAB278B95)\nSystem shutdown begun: NO\nPanic diags file available: YES (0x0)\n\nSystem uptime in nanoseconds: 6478374873002\nlast loaded kext at 4635500660348: >usb.cdc.acm\t5.0.0 (addr 0xffffff7f9ed49000, size 32768)\nloaded kexts:\ncom.getdropbox.dropbox.kext\t1.10.3\ncom.objective-see.lulu\t1.2.0\n@filesystems.msdosfs\t1.10\n>!AMikeyHIDDriver\t131\n>!ATopCaseHIDEventDriver\t3410.1\n>AudioAUUC\t1.70\n@fileutil\t20.036.15\n>AGPM\t111.2.5\n>!APlatformEnabler\t2.7.0d0\n>X86PlatformShim\t1.0.0\n@filesystems.autofs\t3.0\n>!AUpstreamUserClient\t3.6.8\n@kext.AMDFramebuffer\t3.0.2\n>!AHDAHardwareConfigDriver\t283.14\n>!AHDA\t283.14\n@kext.AMDRadeonServiceManager\t3.0.2\n@kext.AMDRadeonX5000\t3.0.2\n>!AGraphicsDevicePolicy\t4.5.9\n@AGDCPluginDisplayMetrics\t4.5.9\n>!AHV\t1\n|IOUserEthernet\t1.0.1\n|IO!BSerialManager\t7.0.1f1\n>!A!IKBLGraphics\t14.0.2\n>pmtelemetry\t1\n>ACPI_SMC_PlatformPlugin\t1.0.0\n>AGDCBacklightControl\t4.5.9\n@kext.AMD10000!C\t3.0.2\n>!AFIVRDriver\t4.1.0\n>eficheck\t1\n@Dont_Steal_Mac_OS_X\t7.0.0\n>!A!ICFLGraphicsFramebuffer\t14.0.2\n>!AGFXHDA\t100.1.422\n>!ABacklight\t180.1\n>!ASMCLMU\t212\n>!A!ISlowAdaptiveClocking\t4.0.0\n>!A!IPCHPMC\t2.0.1\n>!AMCCSControl\t1.13\n>!AThunderboltIP\t3.1.3\n>BCMWLANFirmware4364.Hashstore\t1\n>BCMWLANFirmware4377.Hashstore\t1\n>BCMWLANFirmware4355.Hashstore\t1\n>!ASDXC\t1.7.7\n|!ABCM5701Ethernet\t10.3.5\n>!ABCMWLANBusInterfacePCIe\t1\n>!AFileSystemDriver\t3.0.1\n>!AVirtIO\t1.0\n@filesystems.hfs.kext\t522.0.9\n@!AFSCompression.!AFSCompressionTypeDataless\t1.0.0d1\n@BootCache\t40\n@!AFSCompression.!AFSCompressionTypeZlib\t1.0.0\n@filesystems.apfs\t1412.41.1\n>!AAHCIPort\t341.0.2\n@private.KextAudit\t1.0\n>!AACPIButtons\t6.1\n>!ARTC\t2.0\n>!ASMBIOS\t2.1\n>!AACPIEC\t6.1\n>!AAPIC\t1.7\n$!AImage4\t1\n@nke.applicationfirewall\t303\n$TMSafetyNet\t8\n@!ASystemPolicy\t2.0.0\n|EndpointSecurity\t1\n>usb.cdc.acm\t5.0.0\n>usb.serial\t6.0.0\n>usb.cdc.ecm\t5.0.0\n>usb.cdc.ncm\t5.0.0\n>!UMergeNub\t900.4.2\n>!UAudio\t320.49\n>!AHIDKeyboard\t209\n>!AMultitouchDriver\t3410.2\n>!AInputDeviceSupport\t3410.1\n>!AHS!BDriver\t3410.1\n>IO!BHIDDriver\t7.0.1f1\n@kext.triggers\t1.0\n>DspFuncLib\t283.14\n@kext.OSvKernDSPLib\t529\n@kext.AMDRadeonX5400HWLibs\t1.0\n@kext.AMDRadeonX5000HWServices\t3.0.2\n>!AGraphicsControl\t4.5.9\n|IOAVB!F\t800.17\n>!ASSE\t1.0\n>IOPlatformPluginLegacy\t1.0.0\n|IO!BHost!CUARTTransport\t7.0.1f1\n|IO!BHost!CTransport\t7.0.1f1\n|IO!B!F\t7.0.1f1\n|IO!BPacketLogger\t7.0.1f1\n@kext.AMDSupport\t3.0.2\n>X86PlatformPlugin\t1.0.0\n>!AHDA!C\t283.14\n|IOHDA!F\t283.14\n|IOAccelerator!F2\t438.2.7\n>!A!ILpssUARTv1\t3.0.60\n>!A!ILpssUARTCommon\t3.0.60\n>!AOnboardSerial\t1.0\n>!ASMBusPCI\t1.0.14d1\n|IOAudio!F\t300.2\n@vecLib.kext\t1.2.0\n>!ABacklightExpert\t1.1.0\n|IONDRVSupport\t568\n@!AGPUWrangler\t4.5.9\n@!AGraphicsDeviceControl\t4.5.9\n|IOSlowAdaptiveClocking!F\t1.0.0\n>IOPlatformPlugin!F\t6.0.0d8\n>!ASMBus!C\t1.0.18d1\n|IOGraphics!F\t568\n>!AThunderboltEDMSink\t4.2.1\n>!AThunderboltDPOutAdapter\t6.2.3\n@plugin.IOgPTPPlugin\t810.1\n>usb.cdc\t5.0.0\n>usb.networking\t5.0.0\n>usb.!UHostCompositeDevice\t1.2\n>!AThunderboltPCIDownAdapter\t2.5.2\n>!AThunderboltDPInAdapter\t6.2.3\n>!AThunderboltDPAdapter!F\t6.2.3\n>!AHPM\t3.4.4\n>!A!ILpssI2C!C\t3.0.60\n>!A!ILpssDmac\t3.0.60\n>!A!ILpssI2C\t3.0.60\n>!AThunderboltNHI\t5.8.0\n|IOThunderbolt!F\t7.4.6\n|IOEthernetAVB!C\t1.1.0\n>!ABCMWLANCore\t1.0.0\n>mDNSOffloadUserClient\t1.0.1b8\n>IOImageLoader\t1.0.0\n|IO80211!FV2\t1200.12.2b1\n>corecapture\t1.0.4\n|IOSkywalk!F\t1\n|IOSerial!F\t11\n|IOSurface\t269.6\n@filesystems.hfs.encodings.kext\t1\n>!AXsanScheme\t3\n|IOAHCIBlock!S\t316.40.3\n|IONVMe!F\t2.1.0\n|IOAHCI!F\t290.0.1\n>usb.!UXHCIPCI\t1.2\n>usb.!UXHCI\t1.2\n>usb.!UHostPacketFilter\t1.0\n|IOUSB!F\t900.4.2\n>!AEFINVRAM\t2.1\n>!AEFIRuntime\t2.1\n>!ASMCRTC\t1.0\n|IOSMBus!F\t1.1\n|IOHID!F\t2.0.0\n$quarantine\t4\n$sandbox\t300.0\n@kext.!AMatch\t1.0.0d1\n>DiskImages\t493.0.0\n>!AFDEKeyStore\t28.30\n>!AEffaceable!S\t1.0\n>!AKeyStore\t2\n>!UTDM\t489.41.1\n|IOSCSIBlockCommandsDevice\t422.0.2\n>!ACredentialManager\t1.0\n>KernelRelayHost\t1\n>!ASEPManager\t1.0.1\n>IOSlaveProcessor\t1\n|IOUSBMass!SDriver\t157.40.7\n|IOSCSIArchitectureModel!F\t422.0.2\n|IO!S!F\t2.1\n|IOUSBHost!F\t1.2\n>!UHostMergeProperties\t1.2\n>usb.!UCommon\t1.0\n>!ABusPower!C\t1.0\n|CoreAnalytics!F\t1\n>!AMobileFileIntegrity\t1.0.5\n@kext.CoreTrust\t1\n|IOTimeSync!F\t810.1\n|IONetworking!F\t3.4\n|IOReport!F\t47\n>!AACPIPlatform\t6.1\n>!ASMC\t3.1.9\n>watchdog\t1\n|IOPCI!F\t2.9\n|IOACPI!F\t1.4\n@kec.pthread\t1\n@kec.corecrypto\t1.0\n@kec.Libm\t1\n\n\n"`

System specs:
iMac (Retina 5K, 27-inch, 2019)
3.6 GHz 8-Core Intel Core i9
Radeon Pro Vega 48 8 GB

All settings were on Ultra

A quick update: switching Render to OpenGL in Graphics settings seems to have helped so far. The game is certainly more stable. That said I didn’t have to reduce quality settings at all.

switching to openGL gives me extreme pixelation, which disappears if I tab out of the game but comes back if I tab back in. with Metal, it doesn’t pixelated but It does cause kernel panic and crashes mid game. Definitely something wrong with macOS Catalina and SC2.

Thanks for the reports, everyone! Sorry for not posting in awhile. We are aware of the issue and tracking this on our end. There’s been many reports of the Crashes with Kernel Panic on Metal API graphics related to AMD/Radeon/Vega graphics. This may be a driver issue or an API issue that our team will want to look into.

For those of you with Radeon or switchable graphics and on Mac OS 10.15 Catalina, could you provide the details under Apple Icon > About this Mac (including the Mac model/year, Processor, Memory, and Graphics)?

Some systems may have a switchable graphics that include Intel graphics and AMD graphics. There’s no easy way to force the Intel Graphics without using third party programs, but it may be worth trying to disable Automatic Graphics Switching (System Preferences > Energy Saver, toggle off Automatic Graphics switching).

This issue has been escalated to our team to look into for any API or driver compatibility issues with Catalina. Thanks again for your patience!


This is not relevant to every single crash reported. If you are experiencing crashes, but are not on Catalina or do not have a Radeon Graphics card, please create a new thread so that these can be looked into case by case. The following steps can help with some crashes:

  • Switch to OpenGL - In SC2, go to Options (Press ESC) > Graphics (Default tab) and change the Render API to Open GL 4.1 (Beta)
  • Turn off Automatic Graphics switching - Go to System Preferences > Energy Saver, toggle off Automatic Graphics switching.
  • Reset in-game options.
  • Check for Mac OS updates - For Catalina, it should be on 10.15.1 now.
  • Quit Unexpectedly crashes - Rename Computer Host Name.
  • For systems that are restarting when StarCraft II is launched, this is a driver or hardware issue. Reinstalling the appropriate combo update for the MacOS version, Apple Diagnostics and SMC Reset may be able to help for anyone’s system that is restarting.

No, all these recommendations didn’t help.

Most of all Open GL 4.1 ( Beta ) not working at all - whole picture is lined.

Same here, but my game crashes before opening. It’s not only with the Starcraft 2, also in Heroes of the Storm.

Mac OS Catalina, 10.15.1. MacBook Pro 15" (2018).

Thanks for the continued reports! Our team is aware of the kernel panic/crashes happening with Radeon Graphics and working on a resolution. It’s been reported to happen on Heroes of the Storm as well. Personally, this appears to be tied to a driver issue with Radeon graphics on Catalina that may require an MacOS update in the future. It will take some time to resolve because of the complicated nature of the driver issue on Catalina.

Out of curiosity, since this works with Heroes of the Storm for some graphical issue on OpenGL, does it help to try setting the Shaders to Medium in Options > Graphics?

Still crashing the game and my imac they wanted a new thread if you have a Radeon Pro 575 4 GB graphics. Sometimes the game works (rarely) and it will either crash the game or my imac. I have tried everything they have suggested but nothing works. Been going on sense the os upgrade to catalina. Some options they suggest i do not have that option. I even uninstalled and reinstalled still nothing.

As an update, our team has been working on these kernel crashes. There’s no ETA on when this may be resolved since it does appear to be a driver issue , but it should hopefully be fixed in a future MacOS update. Please keep watch on any new updates for MacOS.

It’s definitely a frustratingly long time for this to occur because of the complex nature of driver issues, and we appreciate your patience! In the mean time, rolling back to Mojave, or using Parellels or Bootcamp to work around the issue. Neither of these are supported by Blizzard, but may be an option for anyone wanting some way to play until the resolution is pushed. I’ll be monitoring for updates and will let everyone know when the update should be pushed :slight_smile:

1 Like

Hi, another crash. I just upgrade to Catalina from Mojave straight to Catalina 10.15.1. I have a kernel panic twice. I was able to boot into the game and game menus. I loaded first map of Zerg single player campaign. Intro videos were fine, first minute of gameplay also fine, I created then the first overlord an crash and laptop reboot. Second crash wash during the first 30 seconds of a custom melee and then crash again and reboot the laptop. My specs:

Macbook pro 2017 Intel HD 630, Intel Quad Core I7. During gameplay, laptop engages Radeon Pro 560 so no need to deactivates graphic switching.

Pretty frustrated here, I wish I can go back to Mojave!

You can go back to mojave…I did it but came back to catalina…I had to use a back up…I tried what the internet said but it didnt work.

I am backing up to wipe HDD and go back to Mojave. Sadly, three kernel panic in less Thant 24 hours (2 caused by sc2). My laptop came with Sierra and Mojave behaves really great. If your laptop came with Catalina, beware to downgrade, Mojave may not have the drivers of newer hardware.

Beginning to think blizzard really dont care its been what at least 2 months and they still dont have a fix… smh

Same here, my Mac is crashing when I play the videos of the campaign. I had to use it at high instead of ultra and this is solving the problem for now, waiting for solution

2014 imac with all the bells and whistles and now running on Catalina. SC2 worked like a charm on Mojave, but does a kernel panic all the time with Catalina. Can’t really enjoy the game with it crashing all the time. Very disappointed.

It has been a while since the last update…
Running new iMac Pro with Catalina 10.15.1 (Pro Vega 56)
Definitely not planning to fall back to Mojave
Is there a FOM estimate of when a resolution will be reached?
Get the “SC2 quit unexpectedly” crash, game does not launch at all

1 Like

The new Catalina 10.15.2 should have been released today. Please update to this current version of Catalina and see if StarCraft II is still experiencing the kernel panic crashes. If the problem continues on 10.15.2, please let us know.

@HolyMacro, the “quit unexpectedly” crash is not the same issue as the kernel panic crashes mentioned here, please refer to the steps available here.

macOS 10.15.2 is not help for the problem.
I’m using new 16-inch MBP with 5500m, macOS 10.15.2, Metal, the game still crash frequently and has rendering problem