Infinite loading screens?

I’ve been trying to play co-op missions for the past hour, and every time I find a match, I get stuck in the loading screen. It loads about 75% of the way, then stops. It also shows my partner loading about 40% of the way, then stopping. I tried playing a match 4 separate times, and this happened every time. Once, after waiting about 10 minutes, the game returned to the menu screen and had an error message saying “Failed to launch game”. The other times, I opened the task manager, suspended the game, re-opened the game and tried again.

I have never experienced this issue before the most recent patch. I was playing co-op missions normally yesterday. I have tried scanning and repairing the game files, and that did not resolve the issue.

I can vouch that this is an issue.

Try this Can't load custom melee maps

I tried 2 options that were there and they didn’t work


You may need to consult with your Internet Service Provider to check your modem/router for firmware updates and check security settings are not blocking part of the game.


Thanks, but it didn’t solve the problem

Update: I tried playing the game again after the most recent patch. I played around 20 matches and the game worked normally, then this issue started happening again.

I have played several other online games in the meantime, and they all worked normally, so it doesn’t seem to be a problem with my internet.

I also tried the solution here (Leave all chat channels before entering a match):

Didn’t work.

before you launch the game you can turn off the internet then launch the game, next you can turn on the internet again to login.

(solved) infinite loading bar

[Edited by Blizzard] This thread has been inactive for some time. Please be mindful of resurrecting older threads. A new or more recent thread can be created to continue the discussion. Locking this thread.