Compiled 10th Anniversary Achievements Tips / Issues / Bugs

“Hidden Victory” achievement:
Complete the “Legacy of the Void - Amon’s Reach” mission by constructing only Probes and Dark Templar on Normal difficulty.

As I have attempted this a few times already, - including one time where I built nothing and just used the 4 DTs that you start with - I am very sure. There’s no mistake.

Update: Actually, disregard this, for some weird reason, the notification didn’t show up but the achievement now registered.

Same issue with “I’ve Fallen and I Can’t Shoot Up” achievement:
Complete the “Unsealing the Past” mission by construction only Probes and Colossus on Normal difficulty.

Update: Actually, disregard this, for some weird reason, the notification didn’t show up but the achievement now registered.

If you press ‘esc’ to skip cinematic, you might have closed the achievement notification as well.

Struggling with this one. Thanks for the tips, will report back.

Having trouble with “Purification”.

The Core Matrix didn’t even take shield damage when I tried it and it still didn’t count.

Also, some SoA abilities like Solar Lance still trigger fail conditions for “Templar’s Charge”.

Through test maps, it’s been confirmed that the three SoA abilities aren’t failing the achievement anymore.

I’ve created a test map that will alert the player in real time about what is causing that achievement to fail. If you want to try it, it may help you figure out what’s happening and where during the mission.

Thanks - got it. A ton of saving and reloading. But managed to get it with maybe 1 second remaining on the timer!

If you click on a top bar ability and then cancel out of using the ability, it still counts as having used the Spear of Adun. Bummer.

‘’’’’’’'Having trouble with “Purification”.

The Core Matrix didn’t even take shield damage when I tried it and it still didn’t count.’’’’’’
shield damage counts!!! so dont let it take a single hit.

I got a single mutalisk doing 1 strike on it. didnt count. reloaded just before. got a few cannons top right and it worked afterwards.

‘’’’’’’‘I tried on normal - best 196, but for me it rather seems random how much I can kill. (200 mines in novas mission)’’’’’’
easier to get both the gasses. wall off ALL sides with a barracks with reactor. spam reapers and when they push a line, put mines near. after BOTH optionals. save and go right base. use like 50 reapers (I had more) and lay mines just inside base.
after almost all are gone, put 4 mines near larvae. they count. got 20 more on normal. worked like a charm today.’
Had 0 bugs in the last week, other then, SoA. making a beam, using the solar lance fails it. (units that disappear after a few secs).

Someone found another bugged 10th Anniversary achievement. I replied with what the issue is.

If the part that is struck out is meant to imply it’s fixed, I don’t think it is. I finally got this after several reloads and retries with the last two transports. It still gave the achievement only at the score screen and not when all the structures were presumably killed (let’s face it, it’s just creep tumours that get missed).

And to ensure there wasn’t some end-game-animation bug, this time I skipped it and got the achievement at the score screen. Feels like this one is still bugged.

Also, if you’ve killed off all existing structures, before the final run with nyduses or aerial reinforcements, then you have killed all structs on map and the achievement should be awarded right there, instead of further waiting for the last wave’s creep tumours to get created…and then needing to be killed.

1 Like

Thanks. It was claimed to be fixed via patch notes, apparently not. :frowning:

I don’t think I quite get this one though. If you can elaborate more will be great. :slight_smile:

Sure. From what I understand of the fix wrt the (previously) struck out lines:

…is that the achievement is awarded in-mission once you’ve cleared all the zerg structures. Which means we should get it once the last existing struct is killed. However, every time there’s one of those enemy drops to attack the convoy, it usually puts down a creep tumour that easily gets missed - and it’s a newly created structure that only got created by the enemy drop - it wasn’t it on the map before. (That makes the achievement a little irritating.)

Now, I killed those each time but I only got the achievement when I was at the score screen and after skipping the end-game animation. So I should have either got the achievement in-game when I killed the last tumour (which I would have in order to get it at the score screen), or I should have got it when I cleared the map before the last convoy - since there’s no “current” structure on the map at that point. New one’s get created from the drop but nothing else.

Worth noting - even if I hadn’t cleared all the creep tumours in my prev runs, thereby not getting the achievement, when I reloaded a mid-game save, completed the game, killing off everything I could see, it should have still given me the achievement in-game in that run rather than at the score screen. So defi still bugged.

1 Like

In the same vein, Full Coverage is still awarded at the end of the mission despite the patch notes stating it’s awarded during the mission.

1 Like


Happen to read this, not sure if it is legit. :slight_smile: Sorry for the trouble, only if you have the time.

I’ll check it out for sure!

I have a problem with Nova achievements, the game can’t unlock any, I do all in normal difficult and I’m assure that I’m log-in. And I never disconect.

Might need to monitor because there are 2 posts regarding Nova achievements not registering. Not sure if it is the same as the Kerrigan Co-op achievements issue (where some achievements ‘broke’ during patch). Just putting this here since one of the flagged achievements deal with a 10th Anniversary one for ‘Raszagal’s Retribution’.

I am also unsure if testing in map-editor will identify the issue, since it might be a server side issue rather than the game itself.


Here is a Blue’s post relating to achievements not updating. Perhaps it might solve the issue:

Looking at the triggers, that shouldn’t be possible.

To check, I did a test in the editor. I reproduced DiamondQuant’s steps:
Killing the 3rd base, then killing the main base, while leaving the 2nd base intact.

After killing the main base, I didn’t get the achievement. Only after killing the 2nd base did the achievement pop.

That’s how it is now at least. Perhaps on August 5th when DiamondQuant posted it was bugged, but was later fixed.

1 Like

Fix: The order of activating the power cells !

Only works if you start with the top right power cell.

If you go around from the bottom to the right and try to finish at the top power cell it will not work. You finish the mission without the achievement.

I tried many times, until i switched power cell activation order…