After patch 4.10.1 "Surrender" bug

After latest Mac patch, SC2 starts > Versus > (Any Choice) > Game is starting > popup screen says “Attempting to Reconnect – SURRENDER” > Game stays stuck there or clicking surrender button disappears the popup but game stays stuck and must be Force Quit.

Going through all the steps for connection/disconnection issues has no effect. Scan and repair has no effect. Deleting Battle dot net folder has no effect. I have no Internet problems and all other programs function. It’s a patch bug. OS High Sierra with all updates.

1 Like

LATEST – After going to a Campaign and exiting, I was then able to do Versus and the problem was resolved. Why? No clue. Seems all good now.

that suggest that your harddrive is too slow to load the game fast enough. i once experienced that on a toshiba harddrive where i kept dropping because the harddrive was too slow.

This issue is not resolved. Played 4 games last night and each time during larger engagements the game would freeze on and off and eventually dropped me after the counter reached 0. EXTREMELY frustrating for all players involved.

that means that someone lags. that is not something that blizzard can fix.

It’s not network lag. The client is dropped as the GFX are freezing and stuttering post patch. Whatever code changed is causing this issue.

no, i get no such problems. at least one of the players lags and drops. i have an almost new pc though.

This is a Mac tech forum. OSX Mojave 10.14.5, the game is stable on PCs.

mac, pc, it does not matter in this case. someone is lagging the game.

Thank you all for your reports so far! Can each of you experiencing the issue provide the following information?

  • Mac Model:
  • MacOS Version:

iMac (Retina 5K, 27-inch, 2017)
macOS Mojave (version 10.14.6)

The game freezes mid to late into the match, forcing me to restart my machine.

Same thing happening to me Ender, game is unplayable at the moment.

Same specs. Maybe there is a correlation. Bad GFX driver?

iMac (Retina 5K, 27-inch, 2017)
3.8 Ghz Intel Core i5
macOS Mojave (version 10.14.6)
Radeon Pro 580 8GB

Update, tried to play last night in Windowed mode as test, gfx set to “high”.

Played 3 games successfully, on the 4th game and system hard froze (mouse frozen etc), 10 seconds later resumed (unfroze). Next game we played, midgame, hard froze and never recovered. Hard power off of system and restart. Maybe there are some console logs I can grab for you guys?

Any progress looking into this caterpepi?

Hey there,

Going through the reporting system I’m not seeing many reports of this happening. I do not see any open bugs regarding this issue either. From here we’ll want to try testing a few things.

  • Does the problem happen on a different network?
  • Does the problem happen on other computers on the same network?
  • I noticed both reports on this thread are using 5k displays. Does the issue happen in a Window Mode version of the game that is set to a smaller resolution?

Let me know. Thanks!

Yes! Kaldraydis finally!

I noticed its not a widely reported bug so I knew this was going to be a more drawn out fix. In fact the only other confirmed report is someone with the same system, OS and version of SC2. Small sample size for sure. Others seem to be having issues but its only that user Ender that matches perfectly.

I haven’t been able to test on a different network, but it doesn’t appear to be related to that. I’m guessing it’s not a connectivity issue in so far that the whole system freezes up (OS, Mouse etc, hard crash).

If you look at my post above you’ll see that I’ve tried to run the game in windowed mode at various GFX settings with the same result. Are there any sc2 logs or OSX console logs I can collect that might help?

Thanks so much for looking into this! I had honestly given up and was ready shelve the game I’ve enjoyed for the past 9 years.

Bump? Any word on this Bliz? Others are coming forward.

Nothing, anything, anybody? Played recently again. Screen freezes, surrender splash appears, mouse locks up, screen flashes red and then stays red and locks the system. Have to hard power off. Only happens in larger mid to late game engagements. Only happens with SC2, all other software functions normally. Same thing happening to other players with the identical system.

iMac (Retina 5K, 27-inch, 2017)
3.8 Ghz Intel Core i5
macOS Mojave (version 10.14.6)
Radeon Pro 580 8GB

Hey, crazyant! Sorry for the delays here. It does seem fairly consistent with similar systems and we are gathering these reports, but there hasn’t been much progress or enough reports through the forums.

Could you contact our Technical Support team here? Working directly on this with you, will give us a better idea of what’s happening with the screen freezes.

1 Like

Thanks for getting back to me caterpepi. I would be happy to work with your team. Reach out to that user Ender as well. He might be able to help gather system logs\reports as needed.

That link you posted appears malformed. Can you relink?

Thanks for reaching out.