"Render Device Lost" Fix for RTX

If the issue is still occurring for you on the 436.02 drivers then you are likely experiencing a different problem. I would recommend submitting a ticket so that we can work with you 1-on-1 to investigate further. Make sure to include your MSINFO and DXDIAG, as well as a list of relevant troubleshooting steps you’ve already done.

I am not getting any UI “render device lost” messages, and I do not see any such messages in my dxdiag or msinfo files, but I do have an RTX 2070 and I’m getting lockups while playing Overwatch. Screen freezes but I continue to hear audio for at least a while, before the audio typically glitches and dies, and my only recourse is to hard reset.

What are the chances I’m having the same problem that is described in this thread?

I had four sticks of RAM totaling 32G and I was having WIndows memory diagnostic errors, so I resolved that by removing two sticks. The remaining 16G passed Windows diagnostics and memtest86, but I replaced it, anyway. New memory passes memory tests.

Overwatch still locks up.

There is nothing in my dxdiag that looks interesting except for the stuff left over from my day and a half of memory diagnostics. All references to adobe have been resolved by uninstalling creative cloud. I’ve also uninstalled everything Razer, after seeing references to razer stuff causing OW crashes.

Overwatch is still locking up. Sometimes I play for hours without incident, sometimes I crash in the first game I play. I’ve run the scan and repair and I’ve updated Nvidia drivers and audio device drivers (Focusrite Scarlett, but OW also crashes while I’m using Corsair Void Pro headset). OW was stable for me until about a month ago.

I’m able to run prime95 and I’m able to run heaven, and I’m able to run them both simultaneously. Temperatures in overwatch are mostly in the 40’s on the CPU to upper 50’s, and lower 60’s on the GPU. I get higher temperatures than that on the CPU while running stress tests, but no crashes.

ETA here’s another hint: Until a couple weeks ago I was playing 1920x1200 60fps, but now have a new monitor 1440p at 144hz. I’d hate to limit frame rate, but I might try that…


This is the same card I have.
32G (2x16) G-Skill Ripjaws DDR4 3200
Asrock z370 Pro 4

0 chance
Create a new thread for your problem or look if anyone else reported something similiar.

I did that already :grinning: This thread was my last, best hope before I gave up :worried:

FWIW I updated to the 436.02 drivers and played a couple hours of custom games without locking up. I’ve had false hope before, though.

Kind of confusing answer you give there ESPECIALLY when the Nvidia changelog mentions ;

Windows 10 Open Issues

  • [Overwatch]: The games crashes with “Your rendering device has been lost” error. [2482278]

I understand there might be some development ongoing on the background. But you answer implies if you still have it then it’s another problem

Thank you all for your continued reports! To clarify, while Overwatch is called out in the release notes for Nvidia, we have seen success with the 436.02 drivers for those impacted by the RTX Rendering Device Lost error if the OverwatchTest.exe or the Nvidia Profile Inspector worked around the issue before.

Please try updating to the Nvidia 436.02 drivers and launch from the Blizzard Application. It’s recommended to run through a few Practice vs AI matches first. If it continues, please continue to use the workaround before with OverwatchTest rename, here.

Let us know if the new drivers help or if the OverwatchTest.exe still works for you. We’re continuing to investigating this; your reports are greatly appreciated and helpful!

If the rename did not fix the issue before, then it is a different issue from the reports on this thread. As Render Device Lost correlates with the Window’s Timeout Detection and Recovery (TDR) to help recover the graphics when it freezes, the causes for this error can vary (from other application conflicts, drivers, windows, or hardware issues) and will need to be investigated individually through a new thread or contacting our Technical Support team.

1 Like

At this point im actually scared to use everyting else then the Rename workaround. Even tho i have to login everytime.
I just managed to dont get -50SR every 5th Game and hit Endorsement Level 4 again for the felt 10th time (more like 5th time) without crashes.
So please dont expect me to be the “Test specimen” for a “supposed fix”.
At this point i will wait for people to confirm this really, really works.
Sorry …, i know its nVidia’s optimization crap, but im done currenlty.
GL & HF Everyone !

I’ve tried the rename, I’ve tried things listed in all the other threads. It’s still not working, still getting rendering device lost within minutes of every. single. game. The game is completely unplayable and I’m at a loss to how this can be an issue of almost a year with one of the higher end gpus and one of the biggest game companies in the world. This type of error should be an issue on a $700 card and a game that is not THAT graphics intensive. I can play the game on my onboard gpu, it’s ridiculous that some how it’s freaking out my rtx 2080.

well… im on a gtx 980ti… tryied the rename fix, the nvidiaprofileinspector, messing with reducing clocks, resinstalling the game, cleaning videodrivers (ddu), installing old drivers, new drivers ( 436.02 ), new hdd, installing extra coolers, formating windows… and i still get this damn error. im just tired… its just overwatch… any other game runs fine… overwath in lowerst settins cant run… i was so exited about 2-2-2… but i couldnt play this beta season becouse this error.

I just installed a brand new RTX 2080 Super and the latest 436 drivers. Just got the crash. imgur com OK2jRvy

This week is actually the best time to try it out since role q is still beta. Might as well try it out before the new comp season is live next week.

A post was split to a new topic: Red Panda - Rendering Device Lost

Hey there friends,

Just jumping in here to let you know we are still watching this issue. The new driver has causes a significant drop in the number of these errors we are seeing. With that said, we can try a few things for our Nvidia users.

Note: If you are not on an Nvidia GPU and have the render device lost error, please open a new thread.

One thing we would like to try, if you have updated and still have the problem, is a clean install of the new drivers.

Clean driver install (Click to expand)

You can do this by doing a custom install …

…and a clean install after downloading the new driver. :slight_smile:

Next, if this does not help, we would want to verify the hardware is not overclocked. Could we run HWmonitor while you play, then after a crash get us pictures of the data in the utility?

Let us know how things go my friends! We only want you to be able to play.


Trying the new driver with the clean install, I’ll update on how it goes, and provide HWMonitor stats if it happens again.

As a side note, is your team able to detect this error at all server-side, and restore lost SR due to the crash? My wife and I have lost hundreds of SR due to this issue over the past months, and it’s made playing competitively difficult for us. I understand that any system for lost SR would likely not affect us currently, but if something like this can be implemented in such a way that hardware/software crashes don’t affect (or at least, affect to a lesser degree) SR, this issue would be much less frustrating overall for users with newer hardware, or hardware with known issues.
(Another possible solution would be to allow some time for a disconnected person to rejoin a match in the beginning, as the issue occurs most often for me within the first minute of a match)

1 Like

Nice idea. I hope it’s possible. I have stopped playing Overwatch because of this. I find Quick Play boring because I’m a very competitive player, but I have lost too much SR due to this crash, not to mention my teammates who also have lost because of my crashes. I hope to return if it’s ever fixed, but it has to be sooner rather than later, otherwise we’re going to grow apart or something like that.

My game had been stable for about 2 months, updated to 436.02 but kept deleting profile. After installing latest patch on live I crashed twice in comp and lost 100SR and 30 min suspension.

Increased my underclock to -215mhz and things seem to be ok again.

I do think the underclock is doing the most, seems like Overwatch doesn’t like factory OC on most of the cards, I increased my underclock until the boost clock was matching reference of 1710mhz.

1 Like

The profile deletion didn’t help me.
I think it’s unacceptable that “Overwatch doesn’t like factory OC…”. I don’t care what it doesn’t like. It should just run like any other game. This issue can be traced back to 2017 even. About time Blizzard stepped up their game. Might be an Nvidia issue, too, but every game works except this.


I’m still crash free with the new 436.02 on my RTX 2080.

New? There’s a newer version, 436.15. I tried yours too, and I still crash. Which GPU do you have? I have a Gigabyte Aorus 1080TI Xtreme Edition.

Yup, its crashing again. I guess I can’t watch youtube while playing overwatch…

RTX 2080