Overwatch won't start

Every time I try to open overwatch it starts to say playing game like usual but then changes back to the play button. There is no error message and nothing happens. I’ve tried everything, restarting my pc, restarting battle net and uninstalling and reinstalling the game but nothing changes

1 Like

Try scan and repair. My friend had a similar problem and it fixed it for them.

i already tried that and it didnt help

Make sure to include your DxDiag (here or on Pastebin.com and link us). The most common cause is Razer Chroma/Synapse blocking the launch.

what is DxDiag? and i dont have any razer hardware or software, if that is what razer chroma/synapse is

Are you in EU? Servers are messing up.

ye i am eu but my friend just tried and he loged on fine so idk?


what I have tried so far:
 - scan and repair
 - uninstall and reinstall
 - close anything to do with battle net on task manager
 - restart my pc

there is no error message but when I press the blue play button it darkens and says launching, it then says playing now and end up just going back to the blue play button

It seems the DxDiag crashed while running, which isn’t something you want to see. I also noticed you’re a bit behind on Windows updates. I recommend manually checking for and installing those, then capturing a new DxDiag. This report wasn’t able to gather information on some of your hardware and is showing Windows error codes when trying to launch the game (issues with Windows itself, not the game client or Bnet).

I’ve updated my windows and have manually checked twice but still cant open overwatch, the same thing happens.

new dxdiag:

Heya. When this usually happens it’s due to another program or a service not letting the game initiate correctly. On the DxDiag I do see you have some BEX errors, which are memory related, and also the storage drive info wasn’t gathered which can indicate a Windows issue.

Best bet for now is to check your third party programs first. Programs with overlays and security programs are the most common ones that would cause it. If you have a Razer device be sure to check out our pinned known issue topic as well.

If you’re still having the issue sending a ticket to support would probably be best. Be sure to include the Msinfo as that would give us much more information than the DxDiag and maybe we can pinpoint the exact cause with it.

i turned off a nvidia geforce overlay but the game still didnt open
this is my msinfo:

sorry but I don’t have pastbin pro so it is split a lot
hope this will help help you figure out my issue and thank you for your help/time

Edit: 6 days later:
I’m assuming you have just given up Sadge

Second edit, 8 days later:
is there anything you can do or have found
I just want to play overwatch man

11 days:
is there anything I can do?
I haven’t played overwatch for 2 weeks please

13 days:

it is a pastebin of a justpasteit like because i couldn’t add that link for some reason
it has every ‘Windows Error Reporting’ removed so its smaller
hopefully you can find the issue

actually I think this is the correctly size reduced file

Those new Pastebin links in the second thread you created contain a link to another site, instead of the actual report data. The other site is removing all formatting, making it too difficult on the eyes to read over.

Since the MSInfo has so many errors that it couldn’t fit in one Pastebin before (not great), I recommend installing Ccleaner, and using it to clear your error logs. Then trying to open the client again and capture a new MSInfo and it should fit on Pastebin.

The Error Reporting section is vital, so do not trim it.

And open a ticket in the meantime if you haven’t.

Also, try disabling Windows SmartScreen. That’s a component of the native security software and there are tons of errors coming from it.

Faulting application name: smartscreen.exe

Perhaps Overwatch has never been given the proper permissions to run.

you can try open manually but you will have to login in the overwatch folder:
Overwatch slash retail folder and try to open Overwatch

downloaded and ran ccleaner but still couldn’t run ow
new msinfo files (split into pastes again because they wouldn’t fit in one again):

this is as many as I could do (24hour limit)
will add the others as a edit in 1 day or 2
thank you for your time and hopefully you will find the issue

The file isn’t fitting because the error log is not being cleaned out. You need to specifically select to clear error logs in CCleaner. On the tab for cleaning there are checkboxes by lots of apps/features to clean. Near the bottom is a System heading, and the option for “Windows Error Reporting” needs to be checked.

Edit: Had the title by the checkmark a little mixed up.

I ran ccleaners custom clean with windows error reporting checked but it wasn’t cleared out and the MSinfo was still like 6000 lines

Okay, that likely means the cleaning app doesn’t have sufficient permissions to clean it, or the directory is corrupted. You could also try checking Windows Event Logs.

Since there is just an overwhelming amount of errors happening on the PC, I recommend taking the time to look through all the apps listed and perhaps remove, reinstall and/or update them.

The errors start with on this link: [Program Groups]Group Name Name Username Start Menu Default:Start Menu D - Pastebin.com

Faulting application path: C:\Program Files\NVIDIA Corporation\Display.NvContainer\NVDisplay.Container.exe

I will mention that I see consistent errors (like this one above) from the GPU. There’s no mention of clean installing those drivers. So download Display Driver Uninstaller and remove all copies of the driver, then reinstall the newest ones.

Faulting application path: C:\Program Files\LGHUB\lghub_agent.exe

Additionally, LGHub is causing errors.

If the GPU driver removal and reinstall doesn’t help, you may want to try repairing or even doing a clean install of Windows.