Skillshot/Ability Indicators Invisible

Since upgrading to the new mac pro with the m1 chip, all ability “indicators” (for example, the circle of Kaelthas’s flame strike) are invisible. I have tried changing various graphics settings, reinstalling, and restarting the computer to no avail. Seems like this is a pretty common issue that has been going on for a while specifically with users who have the new m1, but I haven’t seen any progress since first reports around last November. Makes it almost impossible to play ranked, and even casual game modes are far less enjoyable without being able to play properly.


Unfortunately blizzard doesn’t care.

Seems like a pretty simple fix and a developer as huge as blizzard/activation don’t care to fix it

I uninstalled the game, and won’t be spending money to support them any more.

1 Like

Sad… I have too many hours spent on the game to just give up now. Hoping they can figure it out for one of the next patches.

1 Like

I had recently purchased a 14’ MacBook pro with the M1 chip and was experiencing the same issue. While this thread was started in January (11 months ago) and Blizzard has done nothing to fix it - I have recently discovered that by installing Parallels (or any other VM software) and running Windows 11 ARM - you can play HoTs in the Windows environment and this issue appears to be resolved. I hope this helps some Mac users out there get back into what is already a dying game that is too good to let fully die :frowning:


How’s your performance been thru emulation?

I tried it on Parallels, I allocated the maximum 8 cores and 48+ GB of Ram and it runs like trash. I have the M1 Max 64 GB with Premium Parallels. If there is a way to get it to run I’d like to know.

It’s an interesting concept, but the overload is a bummer while both the game and the emulation try to run at the same time.

…still. The below thread may be interested in seeing this, or at least pointing momentum to the cause…