Recruit A Friend Does NOT Work

The rewards are not being given to newly recruited friends. I just verified it myself.
I double checked to make sure both accounts were registered and playing in Americas. The recruit Link is also from an account playing in Americas. But the rewards are not working.

8 Likes

You are right, it is bugged. Can someone please take a look at it.

2 Likes

Same issue here, didn’t get any rewards.

1 Like

No rewards here too.

1 Like

Can confirm it doesn’t work for me either

1 Like

+1.
Same problem here in Europe. I did not get anything.

1 Like

They know, or at least Technical Support does, and have confirmed this is an issue no matter what server you’re on.

Tech support was kind enough to reply and said this is indeed a bug, but can only be fixed by the team here who handle the Bug Reports.

This has been an issue for almost 2 weeks, so we can only hope they have time to address it at some point.

1 Like

Hi!

Can confirm in EU too. I have been recruited, but my veteran friend have not see the ingame progress checker/no tracking available. I am on level 11 + at the start I haven’t got Raynor. My friend says that anyone who recruited not got the boost + hero (Raynor) too. As I know at level 10 I should get Sylvanas, that is not happened too.

It does not work for a lot of people. I tried in NA, it did not work. It is definitely bugged.

EU here. I got nothing too.

So as a new player i cant play untill this is fixed or loose 2 free heros?

Hello, same issue from me and my 3 friends EU region. And I think blizzard don’t pay attention on it :frowning: Have a nice day.

I also have the same problem!

+1
Same issue here
pls fix

I’ve not received anything too (invite from EU to EU)

EggFriedRice#21888 - Blizzard please fix :frowning: I want Sylvanas & raynor aaaaaaaa

+1, this account and another one did not receive an award, EU

+1 This still seems to be an issue

+1 Same issue here, says I already claimed the rewards when I go to the link but neither my friend or I got the rewards

So, it’s been pretty much a year and this has not been fixed yet? I was recruited and I didn’t get Raynor, so I guess it’s still not working… what a shame.

1 year and a half later, the issue is still there. I reached the support, they just told me to reply to this post. We all know this is pointless and like the previous reply said, what a shame.
Please, do not make this a dead game…