Recruit a friend doesn't grant rewards

My friend sent me a recruit link and I accepted, but no rewards have been granted.

2 Likes

Howdy Terracide,

I checked and it appears that you have the 5 day Stimpack added to your account. You would need to reach level 10 to get the next reward.

Hello,

It does not work for everyone. It works for a few people but a lot of people are having issues with it including myself. Please look into it. Thank you.

If you can confirm that you have completed all the requirements and are not receiving the rewards, then it would be best to post your specific issue in the bug report forums as this forum is focused on community based troubleshooting of local system, network and client issues. That way your specific report will be seen by our QA teams who monitor the bug report forums.

I confirmed it, I tried recruiting in both region [NA, EU], neither worked. The rewards are not given. It is working for some people but not everyone.

My account is registered in NA and is recruited in NA, but it did not receive the rewards. I just checked right now and I still did not receive it.

Hi Zenlaka,

Thank you for the reply. The five day stim pack is from the starter chest. I haven’t been awarded the free Raynor and the additional 5 day stim at level 0, after I finished the tutorial.

Hi, I can confirm I haven’t received the reward. I and others have posted in the Bug section. This issue was first reported a week ago, as yet no reply there.

Thanks for your time.

Howdy Terracide,

Based on what you described, this is a bug and we will need to wait for this to be resolved by the bug team. We don’t have any way to speed up this bug investigation nor force them to reply to your issue specifically.

1 Like