New patch ( crashing repeatedly

Can’t we disable Sky Temple while no solution is found?!
Today is December 13 and my Mac is still crashing on Sky Temple shortly after the count down…every …single… time.

It’s holiday time , come on guys…get a temp fix please


Second that. It would be a relief if the devs could temporarily pull the map, until Apple fixes the driver.

Multiple successive kernel panics are putting unnecessary strain on software, filesystem and hardware.


Crashing repeatedly within 5 seconds of launch.

Map Sky Temple

Device: MacBook Pro (16-inch, 2019)
Processor: 2.3 GHz 8-Core Intel Core i9
Memory: 32 GB 2667 MHz DDR4
Graphics: AMD Radeon Pro 5500M

OS Version: 10.15.2 (19C57)


Are Blizzard even looking in these forums?

It is extremely annoying to not be able to play because of one map!!

PS: I know that I could just nerf my settings, but as one mentioned earlier; why should I be the one to fix something that have been a problem for so long?¿

PPS: The least they could do is to reply in some form that is visible to all Mac users! It is better to admit that there is a problem than ignore it and then have a bunch of pissed off users!

PPPS: Sorry for the rant. :slight_smile:

PPPPS: I have even used the HotS’s own crash reporter to confer the issue. And Apples crash reporter after the whole computer went into a Kernel Panic.


Same issue here. On macOs 10.15.2, sky temple. :frowning:

1 Like

Same issue. Crashing all the time. Only Sky Temple, the rest is fine.

MacOS Catalina
Version 10.15.2

IMac 27-inch 2017
Processor 3.8 GHz Quad-Core Intel Core i5
Memory 8GB 2400 MHz DDR4
Graphics Radeon Pro 580 8 GB

1 Like

Just experienced this issue.

Caused a Kernel panic on my 2017 Macbook Pro and then repeatedly ‘Unexpectedly Quit’ after trying to rejoin several times while in Sky Temple.

This is getting really frustrating in combination with the bug where my cursor won’t go beyond the upper right quarter of the screen sometimes when starting the game.

MacOS Catalina
Version 10.15.2

MacBook PRO 15-inch 2017
Processor 2.8 GHx Quad-Core Intel Core i&
Memory 16 GB 2133 MHz LPDDR3
Graphics Intel HD Graphics 630 1536 MB

1 Like

I have the same issue …anyone find a solution yet?

Computer: MacBook Pro (15-inch, 2017)
Operating System: Mac OS Catalina 10.15.2 (19C57)
Processor: 3.1 GHz Quad-Core Intel Core i7
Memory: 16 GB 2133 MHz LPDDR3
Graphics: Intel HD Graphics 630 1536 MB

I tried to changing the game to render lower quality graphics but it doesn’t seem to make any difference. I also reverted all the settings to default and it didn’t make a difference.

1 Like

I’m getting this problem also along with the crashing

MacBook Pro (15-inch, 2018)
Processor 2.2 GHz 6-Core Intel Core i7
Memory 16 GB 2400 MHz DDR4
Graphics Intel UHD Graphics 630 1536 MB

1 Like

any solution to this?i m having the same problem…?

1 Like

same issues here with multiples crashes when I played hoTS and loss so many points on ranked games and be banish for so long. I blamed my Mac until I found this topic.

I tried to change to lower shaders when Sky temple is the map selected, it works for me. But it’s an ugly workaround to fix a bug discover 3 or 4 months ago…

1 Like

about the cursor, just alt tab… it solved the this issue for me.

A new patch has just been released, so I’m sure this kernel panic causing bug has been fixed, right? I mean, there’s no way Blizzard would leave such a major, consistently verifiable bug unfixed for 3 months, right? Right?…

1 Like

Does updating MacOS to 10.15.3 finally solve the problem?

1 Like

Happening here as well on macOS Sierra 10.12.6 (16G29) with latest version as of February 2 2020.

2,5 GHz Intel Core i7
8 GB 2133 MHz LPDDR3
Intel Iris Plus Graphics 640 1536 MB

1 Like

Same problem as everyone else. Hey Blizz, what is the status of the software repair?

New patch, same problem… Been having this problem for almost half a year now. Structures won’t load and minions just fly up and down off the screen.

No, I just had the bug again, right after updating. The bug is still there.


While most of us understand that the issue is not an easy one to fix as it stems from another more basic issue with the driver, it has been affecting players for a very long long time.

Apple has released several updates to Catalina: 10.15.2 and 10.15.3. And there is no indication that it will be fixed in 10.15.4. While the driver issue itself is between AMD and Apple to sort, it is still upsetting to see lack direct attempts to temporarily avoid the bug by Blizzard. Something in the game triggers it. And by “avoiding” I mean any temporary workaround actioned by the devs and not the players.

There have been suggestions of implementing some kind of auto-switch for the shader settings for the ST map, removing it from map rotation, scaling down the usage of effects temporarily, etc.

Once again, the community understands that fixing an issue like this properly takes time and effort (and is a costly endeavour), but any kind of temporary solution provided by the devs will be better than what we have now.

1 Like

Still happening as of today.