[MOJAVE] Mic wont work, won't ask for permision

I already tried windowed mode to see if a notification appears, I got a request from Battlenet but HOTS doesn’t send the permission request, I read in the forum that a patch fixed it but maybe the last patch erased that?

1 Like

did you manage to fix it? i also have request from bnet to join voice group but it wont send the req

Hey there! We’re currently not aware of any issues at the moment, but we’ll keep checking and tracking for issues with Mojave. There’s a few things that we want to check for since this has helped with voice chat issues in the past.

  • Could you make sure Heroes of the Storm has accessibility permissions? Go to System Preferences > Security & Privacy > Privacy > Accessibility. If Heroes of the Storm is listed, make sure it is checked.
  • If the game is not listed here, you can proc the permissions prompt by checking Disable OS Keyboard Shortcuts option under Mouse & Keyboard in Heroes of the Storm.

There is one suggestion that has helped others in the past, but this is not supported by Blizzard. Please only try this if you are comfortable with terminal commands and under your own discretion.

Here’s steps to adjust the TCC.db for Mojave.

–Heroes of the storm is listed and checked on the accessibility panel

I can’t modify files on my computer, so I can’t adjust TCC.db. I will keep using battlenet social chat for now since at least that works :frowning: