No Microphone will work since OSX Mojave update

No microphone will work since OSX Mojave update a couple days ago. Sound comes through just fine, but every mic I’ve tried gets no response in game. They seem to work fine outside of the game. Razer ManO’War 7.1 is my usual headset. I thought maybe it’s a permissions issue, but heroes and battlenet has permissions under accessibility.

4 Likes

There’s actually a fix for this posted in the dead forums. You need to put the game in windowed mode, then go into mic settings and start a mic test. Once you do that (must be in windowed) the apple dialogue box will appear, allowing you to authorize hots to use the mic.

here is the original post: https://us.battle.net/forums/en/heroes/topic/20769029909

1 Like

ok thanks, couldn’t find anything.

this microphone test in windowed mode does not work for me. is there any official answer as to how to fix this?

3 Likes

I had the same issue and a recent patch of HOTS addressed it for me. Mojave requires that apps ask explicit permission for mic access now, but sometimes there are some crossed wires when Mojave and the app disagree about if the app has already asked for access - and apparently there isn’t a programmatic way for the app to query if it already has.

The fix for me was to wipe and reinstall HOTS. When I did that, it trigged Mojave to pop a dialogue asking if I wanted to enable mic access for the game. After I enabled that, everything has been good.

So I uninstalled, updated, tried open window mode. Nothing works. Is it possible that the hot patch that implemented the fix was taken off by mistake when 39.2 came online? Please help, it’s extremely frustrating not being able to use voice.

1 Like

Huh, I wish I could tell you more Tigerson! Is HOTS checked off in System Preferences > Security & Privacy > Privacy > Microphone? Or is it not in the list? Do other chat programs like Discord or the Blizzard Client chat work?

1 Like

So I was able to enable the battlenet voice chat using the voice test, but can’t get HOTS to request, so it’s not even listed in the privacy settings.

Same here, and happening with a friend who plays HOTS too. Tried windowed mode and Test Mic, no pop-up and no entry in the Privacy settings.

Does anyone know how to disable Mojave’s privacy setup outright.

1 Like

Hi Andrew, it’s built into the guts of Mojave (it’s a “feature not a bug”) so you can’t disable it, short of downgrading your OS. Unfortunately Apple didn’t build a lot of QoL for their development partners with this permissions change, e.g. apparently there is not a programmatic way for an app to re-pop the permission dialogue, it only gets one shot and if you missed it, that’s that.

For me, I was able to completely uninstall HOTS and the BattleNet client - deleted off the computer, reboot, etc. Then download again and reinstall clean. After I did that, Mojave redirected them as “new” apps and popped the security permission dialogue again and after I granted permission on them, it worked.

This is both an Apple and a Blizzard issue. Apple required that apps in Mojave update their plist to pop the dialogue, Blizzard did that in an earlier patch. But I also have the sense that Mojave’s process is buggy for granting permissions. Aside from clean install, I don’t know what else to say - good luck.

2 Likes

Hi, I found solution, but it a bit complicated and must be used if any other doesn’t work for you:

  1. You need to disable MacOS security, for direct access to DB with this security data. This can be done by:
    1.1 Running Mac using Command + R key (Recovery Mode)
    1.2 After running Recovery Mode, using Utility -> Terminal, execute command: csrutil disable
    1.3 Reboot
  2. You need to manually add record to DB of HotS:
    2.1 In terminal type: sqlite3 ~/Library/com.apple.TCC/TCC.db
    2.2 In sqlite console type: INSERT or REPLACE INTO access VALUES('kTCCServiceMicrophone','com.blizzard.heroesofthestorm',0,1,1,NULL,NULL,NULL,'UNUSED',NULL,0,1541440109);

After this manipulation you should be able to use Microphone in HotS and it should appear in Security tab.

!!IMPORTANT!! After this you should restore MacOS security by repeating step 1 with csrutil enable

2 Likes

Do you think there is any hope of blizz implementing an easier fix, or should I just go for it? This does seem a bit complicated/not really sure what happening in all these commands.

didn’t work for me. couldn’t access the database.

I wouldn’t be surprised if you have to sudo some of those…

Omg this is really irritating. Is there gioing to be any fix???

3 Likes

For anyone else that finds this post, since patch 40.0 I was able to get the permissions dialog to appear by entering Windowed mode, and use the Mic test feature.

2 Likes

AndrewC’s solution worked for me. Thanks!

This thread has been inactive for some time, closing this thread. Please be mindful of resurrecting older threads. A new or more recent thread can be created to continue the discussion.

1 Like