Login screen stuck on loading


#1

*edit nvm, just saw the cancelling of HGC. So upset, not planning on logging in for while (ever?) so don’t really care about getting this problem fixed. admins I know you had nothing to do with it, so not flaming you, but yeah, just upset. thanks for all the work over the years anyway.

My HotS login screen is stuck on loading after installing the latest patch (I took a screenshot, but this forum says “sorry you can’t post links”). ie. the game opens normally to the screen with “options, quit” on the right and region select on the left, but the center of the screen is just a spinning loading circle where I would normally enter login details.

It stays stuck like that indefinitely. Trying other regions has no effect (I play EU). Have tried deleting the battlenet cache, restarting computer, disconnecting and reconnecting the internet.

I play on my university’s network, but I doubt this is the problem: I have a friend in the same room as me who connects to HotS without issue. I am also able to log into SC2 without problems, the problem is only with HotS and only since I installed the patch.


#2

Having the same problem as stated above


#3
  • The previous version had a bug where if you alt-tabbed during the “authenticating” part of the log in process then logging in would fail and it you throw you back to the log in screen. (I havent tested if this error still occurs in the new version).

  • Logging in automatically as the game launches works fine for me at the moment (it also did in the previous version). However:

  • A bug occurring in the new version results in the log in form never loading if you log out from in game when trying to switch re-log, switch regions, or change accounts, etc.

  • Switching accounts or region on the Bnet launcher and then relaunching the game works as the game auto-logs in when starting up.

  • Bnet launcher has been very unresponsive with the lastest version, sometimes it wont close properly and has to be terminated several times before starting up correctly.
    It also becomes unresponsive if you let it for a bit instead of launching the game right away.
    And then again becomes unresponsive for a while (or indefinitely) after the game shuts down.

Nothing on my end change during the emergence of this bug.
It was working fine prior to the xp changes patch.
And after patching the log in bug started.
I even launched the game on EU instead (which required the patch to roll back since EU wasn’t using the patch yet) and everything worked great there. But then when going back to NA and re-patch it the bug happened again.
So it’s most definitely something that changed with the patch and not on my end.


#4

Same issue. I thought it will be fixed with newest patch, but apparently nobody cares.


#5

Yep, same issue here. Entirely unable to play the game.

I went into more detail here: https://us.forums.blizzard.com/en/heroes/t/cannot-connect-on-launch/9509


#6

This issue still persist, please someone look into it.
Old log in screen was working just fine.


#7

I have the same issue- it has been around forever. 5-8 log in attempts before it actually goes through. Annoyed because i enjoy the game but it receives no support whatsoever.