After the Last Patch, cannot open game on MAC

Personally, another possible solution (it worked for me) is inside the game, under options, change the server that is connected, unchecking the “Choose the best server” option and select any one of them.

The game was back to normal at the same time!

Hope it helps some people!

how are you going to choose a best server if you can’t open the application… I think you got the wrong thread mate.

1 Like

10.14.3 and not running.

What computer name should I put in?

This also worked for me! Changed the hostname, then changed it right back to what it was originally, an the game suddenly launches & works.

The game still doesnt work for me after the last patch. What hostname should I put in? I’m not sure what I have to do. Thx :slight_smile:

It worked! I love you Fidibus lol

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

WOW! you’re a hero!!

Same issue with last patch for StarCraft II.

Same fix! hostname change.

A post was split to a new topic: Heroes of the Storm Crashing

Same here, the change name on preference repair my game too…

Thanks a lot !

Im having the same exact issue still

the game on a mac is a joke really. Can’t believe Blizzard made it

Same issue here. I have a Mac and a PC and they are both broken.

Hey all,

This is the work around for the bug we are currently investigating in this thread. If this does NOT fix your issue, it means you are having a different error. In that case, you should post your own thread so that crash can be investigated separately. I recommend when you start your thread you inform us that you already tried renaming your user profile, so we don’t repeat the step with you.

The solution for me was to trash all the files in the config folder located at /Applications/Games/Heroes of the Storm/HeroesData/Config and then launch the game. It took a while for it to open but when it finally did everything was working fine - I just had to change up all my settings back to the way I like em afterward.


I am on El Capitan 10.11.6 and have tried all that is suggested above:

  • deleted/reinstalled
  • changed computer host name
  • deleted /Applications/Games/Heroes of the Storm/HeroesData/Config
  • reset game settings.

When on battle net application, clicking ‘play’ simply doesn’t launch the game.

This started since a patch in early 2019.

Any fix on the matter ?

Hey, Markusmagoo! Heroes of the Storm’s only supports Sierra (10.12.6) and above. Please check out our system requirements here.

This thread has been inactive for some time. Please be mindful of resurrecting older threads. A new or more recent thread can be created to continue the discussion. Locking this thread.

This topic issue has been added to the Known Mac Technical Support Issues.