Account seems corrupt, can't move in game or select anything just on that account


Randomly when the game starts I can’t select a talent, the letters (ie Q,W,E) next to the talents are missing, the letters (Q,W,E) are missing on the ability buttons on the bottom of the screen, and it won’t let me right click out of the base. I thought it might be a random mouse issue in-game (as I’ve seen described in other threads) but when using a friend’s computer (that works fine playing HotS on his account), I encounter the same issue when trying to play on my account. I started a new account on my computer and it works fine. So this issue of not being able to move or select talents only exists on my primary account. Any ideas???


Hey, MaxPower85!

Can you locate your Documents/Heroes of the Storm/variables.txt file and delete this file? This should default your in-game settings and revert any possible changes made on profiles.



I can’t seem to find the file you’re referencing. To clarify I play on a Mac, but as I mentioned it’s happening no matter what comp I play on, but only when logged on to my primary account. I don’t see anything under Documents on my comp, and when I search Applications/HeroesOfTheStorm I don’t see anything within those folders called variables.txt. Is there perhaps some other way you can direct me to that file?


Okay, I assumed you were on a PC as the Mac forums are here:

You are likely experiencing the Mac Mouse issue outlined here: Unable to move cursor in game (Workaround)


Sorry for not clarifying earlier or posting in the right spot. I actually did see that post and tried that and did add the checkmark for HotS as it suggests but it didn’t change anything. It’s confusing because it’s not a computer issue. As I said, I can play on my friend’s computer that works fine for him and when I log out of his account and sign into my account, the problem persists. Or when I use my laptop and log on to my new account the gameplay works perfect. So somehow it’s my account that is causing my issue and not my computer. Does that make sense?


Hey MaxPower85,

This sounds like a hotkey issue to me, since hotkeys stay with your account across computers. Does resetting your hotkey profile to use the default profile alleviate this issue?

Variables files as well as hotkey files can be found in the following locations on Mac:
~/Library/Application Support/Blizzard/Heroes of the Storm/Accounts/[ACCT#]/Variables.txt
~/Library/Application Support/Blizzard/Heroes of the Storm/Accounts/[ACCT#]/Hotkeys

You can also open the folder from the Hotkey menu when selecting profiles.

~ Fizivix


That was exactly the problem!! Resetting the hotkeys fixed it. Thank you so much for your help!