[Main Thread] HS:NGRESULT DB ERROR:303:0 Error

Hello i just installed the game after a long hiatus and i’m not able to connect to European servers, i looked around and tried some of the suggested fixes but to no success. I read that it’s an issue that’s tied to some accounts, is there any way to resolve this, would love to be able to enjoy the game again.

Thank you.

25 Likes

I am having the same issue, also in the EU also tried to log back in today

I am able to login using a different account so i’m not sure what the issue could be.

same issue on ios. just downloaded today and uninstalled twice but still not working

I’m having the same issue with my account.

So, on my main account i can’t connect to EU or NA servers but i can connect to Asia and on my secondary account i can connect to all regions with no problem. Never experienced such a thing.

Same issue :slightly_smiling_face: wanted to come back but “swawolne skrzaty” are ruining everything

Same issue here. I have not logged in about 2 years probably, have the error both on mobile and pc.

I have the same problem, I haven’t played this game in half a year and now I can’t even launch :ragey

Same issue here. I’ve not logged in for a long time and error is not fixable with any known methods.

I got this too. Been stuck at the “playful sprites” for 2 days now after returning to play. Other games have been great on my return but not Hearthstone.

This little “Sprites” make it all the way to Chile. Both PC and Android version compromised. Have tried several times and techiques with no result. Im sure I wasn’t too long away from here.

Same, back after a long time, NA and Asia severs work, but not EU

Same problem here. I can log in on NA and Asian servers but not on the EU (where I am). Can’t log in on my PC neither on my phone, I get the same error : HS:NGRESULTDB ERROR:303:0 . I saw other older post about this issue, I tried the things they suggested us to do :

" 1. Delete the Hearthstone option files:

  1. Press Windows Key + R to open the Run dialogue
  2. Type %LocalAppData% into the Run field and click OK
  3. Open the Blizzard folder.
  4. If there is no Blizzard folder, ensure to show hidden files and folders.
  5. Delete the Hearthstone folder.
  6. Try creating a new administrator account to resolve permissions issues.
  7. Disable or temporarily uninstall any security programs, which may mistakenly identify the login module as a security threat.
  8. Try closing background applications to resolve any software conflicts."

None of this worked for me.
Uninstall and reinstall didn’t work.
Logged on a different administrator account (I had a problem similar to this one with another game (RDR2) where this solution worked). It didn’t work.
I’m kind of doubtful about any software conflict because it doesn’t work either on my phone. I’m not a specialist but it seems to me the issue comes from my account or the game for whatever reason.

2 Likes

I’m in the same boat as OP, except I can’t play on NA servers. I also tried all the fixes from the post above, to no avail.

I have the same issue unfortunally, I tried to play after I quit the game last year but i cannot connect to EU servers.
NA servers work just fine but all the cards are in EU so I don’t know what to do, I already tried everything.
I hope this will be fixed soon.

Same here. Trying Americas region :confused:

Just got this issue this morning, was playing fine 8 hours ago. I’m playing on my Android device so it doesn’t give me an option to switch regions and I can’t delete any temporary data. Playing on NA servers.

Howdy!

We are aware and investigating reports of the login error: HS:NT304:303:0 occurring often in single regions. Currently, it appears to only impact a single region many players can switch regions and then log in. Our developers are currently investigating this issue as fast as possible. We will keep this thread updated on any changes or when the issue has been resolved.

Thank you.

12 Likes

Yup, had this for two days now. Long time didn’t play, installed it. Played like 2 solo things and went afk for dinner. Came back and I get this.

Welp, had a response from support saying they are aware and looking into it. It’s apparantely and obviously widespread.

edit; in all fairness I remember why i stopped playing