25.4 Known Issues

Hello all,

Patch 25.4 is now live, bringing the Return to Naxxramas Mini-Set, the Mercenaries Mythic Boss Rush, and more! Follow this post for details on known issues being tracked with this patch.

The issues we’re tracking this patch include:

  • Test Subject is temporarily banned due to an unintended interaction in Wild. The card will be un-banned when an adjustment is made.
  • Diamond Zephrys can be found in-game, but the card is not ready yet and is not available.
  • From De Other Side’s art is not showing correctly.
  • In Mercenaries, Old God corruption has reached their Diamond animations, which now aren’t displaying properly.
  • [Resolved 2/14] In Mercenaries, the team is aware that a non-Mercenary card back is appearing in Mercenaries Packs. This is not intended. Mercenaries pack opening has been re-enable. The issue with the packs has been resolved. Affected players received 2 Mercenaries Packs if they opened any Mercenaries packs during the impacted period; affected players received an additional 10 Mercenaries Packs if they opened one of the non-Mercenary card backs in one of those Packs.
  • [Resolved 2/17] We are tracking reports of a bug with the Blazing Transmutation card pool.
  • [Resolved 2/14] The team is investigating reports of players replaying the Hearthstone tutorial and then being unable to progress quests and certain other progression after that.
  • [Added 3/2] The team is aware that there are text/translation issues with some of the 25.4.3 card changes in some languages. These issues are planned to be resolved in an upcoming patch.
  • [Resolved 3/3] Fixed a bug where Blazing Transmutation did not function correctly when there were no minions of the appropriate Cost for the target.

Some players are unable to access the Shop. We have identified the issue and working on a solution. Your reports have identified a workaround for PC:

Some players have reported crashing issues when using the Pixel 6. We are working on this issue. In the meantime, a player has identified a workaround that other players are reporting worked for them:

  • On your Pixel 6, go to Settings → Game Dashboard. In there, set “Use Game Dashboard” and “Game Dashboard Floating Icon” to “Enabled.”
  • Open Hearthstone and a Dashboard icon or an arrow will be visible, usually in the top right corner.
  • Tap that icon or arrow to open internal settings.
  • Change Optimization from “Standard” to “Battery Saver.”
  • Restart the client and check to make sure the setting has been saved. In that setting, the issue should be mitigated.

Thank you for continuing to provide helpful information in our investigation of bugs, and workarounds to them.

Related forum posts:
Patch 25.4.1 Patch Notes
Patch 25.4.2 Patch Notes

We will continue to update this post as we get more information.


There is a bug in mercenaries where if you get a character when opening a pack, that card won’t flip over. I don’t know what character it is but it’s not one of the “rare” rarities…


The Sanctum Spellbender is still bugged for me after the patch. This is what she looks like after I bought the Miniset:


Playing on PC with Windows 10.

Hearthstone is not allowing me to login and asking for a security check. It is not sending the code to my email for verification after multiple “resend code” requests. What’s going on?

                            .................... (FIXED)..................

This is for people who keep saying they don’t listen.

1 Like

Card-Generated Corpse Explosion will detonate until the board is clear even if no corpses exist. This happened from a Corpse Explosion generated by a Jackpot! (Opponent was a Rogues) and by Asvedon, the Grandshield copying that generated Corpse Explosion.

I had 28 mercs packs. Was rewarded a pack for clearing one of chromie tasks but it does not show up, still lists me as having 28 packs, should be 29.


Unable to get Lilian Voss’s Third Equipment in Mercenaries by clearing either The Anointed Blade Encounter in either normal or heroic mode


being unable to progress quests and certain other progression after that. stopped getting xp as well on top of all quests not progressing and lagging alot

1 Like

I have too a problem with no exp for playing:

“[Added 2/14] The team is investigating reports of players replaying the Hearthstone tutorial and then being unable to progress quests and certain other progression after that”

Im angy becouse i pay for Tawern Pass and now cant get the rewards. :c

History of my problem:

  1. Im replay a toturial by clicking Qestion mark in hearthstone menu.
  2. I get a new qestline.
  3. After half-completing a qestline, everything get buggy and i cant progress any qest and gain any exp anymore. ;C

Please fix it.

I’ve noticed a bug with the collection. When trying to access the collection on mobile, the application will freeze and become unresponsive. This happens sometimes when opening the collection, or when turning a page.


Boss rush bosses are in the wrong order. The new ones did not open the 2nd slot. I got 25 renown for killing them. Yesterday’s bosses in tomorrow’s closed tab.

In my collection all the tabs for the different classes are missing.

Also still no mention of the error thats been there for a month with the popup message error when you go into mercernary mode.


Mr Bigglesworth mercenary can give lifesteal (and some other) keyword with headpats, even though that keyword does nothing in Mercenaries mode

1 Like

a lot of my mercs didn’t get back their maxed stats, even if they are actually maxed, and with the new patch it doesn’t let me unlock the myth upgrades for them, since apparently they don’t count as maxed… (and yes i have a bank of coins on all those mercs that i can’t use), other people i heard have same issue, but we didn’t get any response, are they aware?

In Mercenaries, Vanessa Vancleef’s combo always NOT triggering


Renown abilities are not working in the mythic boss rush.

I spent renown to upgrade Yu’lon’s Jadefire Spear to rank 7 which reads “Jadeflame Buffet gives an additional +14 health.” Jadeflame Buffet 5 now reads “Block Taunt and Stealth on all characters for 2 turns. Give your characters +24 Health.”

While playing a mythic boss rush Jadeflame Buffet instead reads “Block Taunt and Stealth on all characters for 2 turns. Give your characters +15 Health.” Using the ability, in a mythic boss rush, only gives +15 health. Mousing over Yu’lon does show Jadefire Spear 7 equipped and correctly reads “Jadeflame Buffet gives an additional +14 health.” However, it is clearly only applying Jadefire Spear 4 instead of Jadefire Spear 7.

Playing a regular bounty shows Jadefire Spear 4 equipped instead of Jadefire 7.

This might be specific to Yu’lon. Cariel Roame’s renown upgrades are working as expected. Yu’lon’s addition to a team is not increasing the level of the team, as shown in the choose a party screen, when paired with another merc that has renown upgrades. When Yu’lon is the only merc with renown upgrades then the team level shows correctly (34 in my case). When paired with Cariel Roame (32) the team level is displayed as 32 instead of, well I’m not sure what it should display. Is it displaying the highest renown level on the team?

I tested this from Windows 11 and from the Android version of Hearthstone. Both are having this issue.


Yes this keeps happening to me on Android on my Google Pixel 6. I thought it was an issue with the update so I uninstalled and reinstalled fresh but it keeps happening


Seems to be working on Mac so not an account issue