Error 24004 Problems connecting to a public server

Issue with joining Public game error 24004。

Hey all! Thank you for your reports! This problem was caused by a server issue with one of our South America servers. Our team has patched this up and this should have resolved those in South America experiencing the issue.

If you continue to experience issues please let us know!

As for those on SEA or Oceanic connections experiencing this issue, It may be related to some of the cable issues mentioned earlier. Just a few questions for those experiencing the issue.

  • What region?
  • Does this happen on a different character?
  • Does this happen on an alternative connection or VPN?
  • Gather a WinMTR file until the problem occurs for 10 to 15 minutes. Copy and paste the text file created and paste it between two ~~~ like so:
    WinMTR Here
    If you have issues pasting here, use Pastebin and post the end of the link. (ie. 123456 for

Thanks again for your reports and any details provided :slight_smile:


Hi, I’m in the SEA region and I’m still encountering this problem, I have tried to connect to different VPN locations but I don’t currently have another character capable of accessing t16 and don’t have time to get one there.

  • I’m located in SEA (Victoria, Australia) but connect to NA.
  • The issue occurs regardless of which character I use.
  • Using a VPN alleviates the issue for me when connecting to Los Angeles, US.

| WinMTR statistics |

Host - % Sent Recv Best Avrg Wrst Last
RT-AC68U - 0 507 507 0 0 21 0
loop[redacted] - 0 507 507 4 5 26 4 - 0 507 507 16 16 38 17
________________________________________________ ______ ______ ______ ______ ______ ______

WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

Same problem joining public Torment XVI Rift games. Error 24004.
Location: Perth, Western Australia. ISP: Telstra

Thank you for the details and reports! For those experiencing the issue, please include all the data requested above. The WinMTR data is helpful for us to compare and gather data to find the source of the issue. It can help speed things up if we need to escalate this to our internal team or our team needs to communicate with specific providers or peering partners where the connectivity issue appears.

1 Like
  • What region? Australia
  • Does this happen on a different character? Unable to test with seasonal characters. Only have 1 seasonal character able to join Public Torment XVI Rift games.
  • Does this happen on an alternative connection or VPN? Tested while tethered to my mobile phone (Telstra 4G) and still received the same error.
  • WInMTR file upload: pastebin: NCMFBpE3
  • Error pictures when trying to join Public Torment XVI Rift games:
    #1: imgur F7ipHDV.png #2 imgur k7K00xw.png

This error does NOT occur on non-seasonal characters.

Interesting, thank you for the details, Hydro! A few of our other games seem to report other connectivity issues with telstra connections and if we can gather a few more tests to compare, it may show the telstra peering node. I’m getting this added to our tracking in the mean time. Thank you, again :slight_smile:


Hi there,

On Optus connection in Victoria Australia. getting the 24004 error when trying to join public Rift game in Seasonal character. Bounties went OK this morning. Havent had a chnace to try any of the others at this stage…

I have had this problem for about 3 weeks and its constant . Im in Sydney australia using our New world class NBN lol with optus .
It happens on any character at any time every day or night for the last 3 weeks .

Something that may be related or not to this issues . For months i have the public rift games showing no games available . but there is, if you just go join . your suddenly in a game , that is well into a rift . ???

So how is Support going solving this issue ??? any updates . I dont think it has anything to do with Telstra . They are not the supplier in australia for our Internet. NBN it the owner of our internet hardware system .

My version of this is cant connect to a Pub rift game… GR’s fine. Only happens when I specify the Aus server. If connected to US, is fine… From NZ

I just got this error and I’m in the US. Plus I can join a t16 GR, but when I try to join a T8 GR game I get the error. It is just the T8 GR and nothing else.

Plus I know about how it works. I have most of the time on avg 18 hops. Sometimes up to 35 hops too. So if I can join a T16 GR game and not a T8 GR game. Then it isn’t my hops that causing the problem or my connection.

Hi i Still having same issue couldn’t joint Pub normal rift code 24004 please help im from Auckland

1 Like

For those who are experiencing the 24004 error, please provide the requested details mentioned above. We’ve only received one report on this issue and in order to investigate this further, the requested information is helpful for our team and greatly appreciated.

1 Like

By any chance can you just fix by updating new patch or something like that im noob of fixing it . Is just won’t let me join normal pub rif any character . Sorry so frustrated . I downloaded that WinMTR don’t seem works or donno how to fix . Once again im from Auckland ( NZ region on american server since vanilla ) . Apart from that u can join bounties pub and GR . (Just not normal rif pub ) . Please help


As technical support, we only assist with technical issues. We are not the developers or have the ability to make changes to the game. If this seems more like a bug within the game, please report this on the #bug-report forums so that this issue can be investigated by the appropriate team.

For anyone wanting for us to look into this issue further, please provide the requested details mentioned above.

1 Like

i am also having this problem rift t16 error code 24004, in western australia, provider is aussie broadband, only happens on seasonal character no problem on non seasonal characters

Does this happen on a different character? - No works on other non season characters (Only happening on T16 with my Seasonal character)
Does this happen on an alternative connection or VPN? - Yes (Mobile tethered)


|                                      WinMTR statistics                                   |

|                       Host              -   %  | Sent | Recv | Best | Avrg | Wrst | Last |


|                 -    0 |   69 |   69 |    1 |    1 |    3 |    2 |

|                  -    0 |   69 |   69 |    2 |    3 |   19 |    3 |

| -    0 |   69 |   69 |   11 |   27 |   67 |   16 |

| -    6 |   57 |   54 |    0 |   13 |   32 |   13 |

| -    2 |   66 |   65 |   29 |   33 |   46 |   30 |

|          -    0 |   69 |   69 |   29 |   36 |  103 |   33 |

|                  -    0 |   69 |   69 |   28 |   43 |  135 |   32 |

| -    0 |   69 |   69 |   28 |   34 |   83 |   31 |

|                  -    0 |   69 |   69 |   28 |   33 |   46 |   31 |


   WinMTR v0.92 GPL V2 by Appnor MSP - Fully Managed Hosting & Cloud Provider

65 posts were split to a new topic: [Main Thread] - Error 24004 connecting to public server