[Diablo II] Cannot download client

I am unable to download my Diablo 2 client. Having the same issue as everyone else apparently.

Yeah, I’m having these issues as well. Can’t download Diablo II or Warcraft III; tried on Chrome, Firefox and Edge.

1 Like

Blizzard - I just paid for a copy of Diablo 2 - Lord of destruction only to find out your installer won’t download… I have cleared the cache. I have removed the old download attempts. I have tried different browsers. Nothing

THIS is the reason I have always pirated games in the past!! Pathetic customer support, etc. I want the game I paid for, is that too much to ask?


This is crazy. I paid and am on my account. The download fails after 2mb… I have my old CDs and download that way but that’s v1.0 and I need the update… Unreal

Same issue here, had to reinstall windows and now I can’t get my classic games back!

Same issue here. I’ve been trying for days, now.

+1, can’t downland D2

Im having the same problem. Cant DL any classic games. I have cleared my cache and tried on two different browsers. Always stops after about 2 mb and says “Network Failure”

Blizzard please need a solution, we cannot download the game from the website. We want to play D2.

Same for me, Blizzard. When I try and download it, it says : Downloader_Diablo2_Lord_of_Destruction_enUS.exe Failed. Even if I try to restart my pc, it doesn’t work. Please help me !

Same problem for me too. Please fix!

Waiting for a fix as well. Contacted support last night and instead of telling me how to fix the problem, closed the ticket when they saw I was on a Mac. It’s not like I don’t have more than one computer…

this was in nov of 19 its april 2020 still no solution? can we get a refund if we choose.

1 Like

Mine does the exact same thing, please help us Blizzard.

same here need help asap

Same problem for me. Please fix it!

I can’t download. It start but download fails in a while.

same here cant download tried different browser and clearing cache and nothing works

1 Like

This thread has been inactive for some time, closing this thread. Please be mindful of resurrecting older threads. A new or more recent thread can be created to continue the discussion, but we are aware of the “Failed - Network Error” issue, please refer to this thread where we’re tracking and gathering reports.