[Main Thread] "Failed - Network Error" with Battle.net Set-up file

when you download the app make sure before you click to download to have your account logged in i didn’t notice i was logged out so logged in and then the app worked let me know if this helps.

This worked for me too. Thanks!

Every time I try to download Battle.net, it just says “Network Error.” I have done all of the troubleshooting that google will supply me with, same thing. Help? Please?

Every time I try to download Battle.net, it just says “Network Error.” I have done all of the troubleshooting that google will supply me with, same thing. Help? Please?

Hi, I’m with Catalina 10.5.4. I’m trying to install battlenet but the when I click to install the app it freezes and I have to force the exit.
Same problem when I try to install Warcraft III Reforged.
Could you please help me with that?

We have been able to replicate the issue on our end, our team is working on a resolution for this issue. For those experiencing the issue, please follow the steps suggested on this post for the Blizzard Application and for Diablo II, please refer to this thread.

Warcraft III and Starcraft I have transitioned over to the Blizzard Application. These classic application installations will install the Blizzard Application. Please follow the steps above.

If you have the application (or Diablo II) installed, this thread is not the appropriate thread. This thread is for failed downloads with the set up file in the browser. Please create your own thread or contact support.

1 Like

It’s absolutely insane to me that as a response to fix a mistake, you all keep re-posting the same link to the same f-ing thread that doesn’t work.

3 Likes

I just put in a ssd into my laptop and have a fresh install of windows. I downloaded all the drivers and everything is up to date, but i ran into the issure that i cannot download the battle.net launcher. I’ve deactivated all the firewalls and even have switched connections and it still has network failure. Please help.

I’m having the same issue, even tried using my iPhone as a hotsport to download the BattleNet Desktop app, and still got the same error. I reached out to a friend to download it for me on his PC and send it to me via Google Drive, he too got the same error.

This tells me that its Blizzard’s fault, they are having issues.

1 Like

I just built a new PC and im having the same problem. Im able to download anything else but the battle.net launcher.

Heya dc2117,

Lets try this alternate link. Let us know if this works for you!

3 Likes

Thank you, that link worked for me.

Yep link works! thanks!

The Americas link worked for me in New Zealand! thank you Americas!

Hi, I simply want a refund for my purchase since I cannot download battle.net app on my mac. Anyone know how to speak to a real customer service rep?

I’ve tried each of the Mac OS Catalina links and they all give me network error message. Can you provide an alternate link that works? I wouldn’t have thought this would have been a difficult fix?

I can’t download the application. have used multiple browsers but the same issue prevails.
Also, I have tried all your solutions mentioned in the previous post.

Look for alternative link for warcraft reign of chaos classic and frozen throne

I have been attempting all day via every possible way I can find to download the bullet net desktop app for Windows I have followed all the steps shown in the troubleshooting etc and none of it seems to work. I click on the button and the separate page starts loading and then it just exits Please help in so close in just giving up