[Jan. 24] Main Thread: Cannot log into app - "Oops something went wrong"

Since yesterday on android phone. Tried updating phone and deleting and reinstalling app and prob still exists. Starting new thread as Dec 2020 thread says resolved.


Same issue here. Started some time last night

Cleared cache/data
different networks
Can log into battle.net website from phone

1 Like

Same here, started today or maybe yesterday evening. The same Login prompt appears and when clicking Login it almost instantly gives the red prompt.

Tried clearing cache and data, reinstalling etc.

1 Like

The same problem, started this morning.

Same thing. Uninstall reinstall didn’t work.

Same here.

I noticed problems happening Saturday night (1/23/2021). I receive messages from friends, that will show up as phone notifications from the battle.net app, but when I try to open the battle.net app to reply, I’m stuck at login screen with the error: “oops, something went wrong”. Closing and restarting the app doesn’t fix the issue.

I can log into my account just fine from my phone using a browser.

I’m on android, Samsung S10.

I am having the same problem it started an hour ago. No matter what wifi network or mobile data I am on it won’t work. I’ve tried restarting, clearing cache and reinstalling . Nothing is working . I have a samsung galaxy s20 ultra

I’m having the same issue. It started last night. I Uninstalled, deleted cache, nothing is working. I’m on an android. Samsung galaxy s10+. App version

Same issue here, Samsung 10+.
tried everything
still no connection. have the latest update aswell.

please fix.

I am also having the same problem on a moto z play 2, the app crashed last night around 9pm Pacific and after that I have not been able to sign in, even after deleting app, clearing cache, resetting phone, changing networks.

Thanks for all the reports folks, this is currently under investigation. Right now we’re seeing this reported across numerous types of devices running various versions of Android.

If you would like to add a report, please include:

  • Device Brand/Model
  • Mobile OS version

Just downloaded the app on my OnePlus 8T today, facing this exact same issue. Authenticator is working. Battle.net app continuously giving me a “Oops…”.

Same issue with me. Cleared the cache, uninstalled and reinstalled, no fix. Tried wifi and data and same issue,

Still have this issue. Multiple uninstalls and reinstalls have not fixed the Issue. Galaxy Note 10+

Since last night I’m getting the “oops something went wrong” when trying to log in on the battle.net app on my phone. Tried uninstall/reinstall, tried different account, tried reboot,tried other phone other account. Issue persists. Replicated on a further 3 more accounts. App works fine if you’re logged in but if you log out and try to log back in it happens.
3 of the phones tested are androids, not sure about the 4th. All apps and system updates are up to date

Same issue, tried all the above. Running Android 8. Cleared cache, data, reinstalled, rebooted, still get instant “oops” message, as if it’s not even trying to connect.

This only started happening 1-2 days ago, can’t remember the first time.


For the last several days, my phone battle.net app has been logging in, but then goes to “Opps. Something went wrong.” And then nothing. It just keeps going like that. Uninstalling and reinstalling have not helped.

Same here. Tried clearing cache and data, reinstalling etc.

Samsung Galaxy S20+ here. Rebooted phone as well.

Hi Everyone,

Thank you all for reporting the issue.

This issue has been resolved, apologies for any inconvenience it caused. Please let us know if you are still unable to connect/login and we can look into it.

– Kraiden

1 Like