Hangs at "Checking Versions" US West

Tried to log in to US West on 7 April (13:30 or 14:30 Bnet time) and got the hang at “Checking Versions”. After 2-3 minutes got the “can not connect to battlenet” notice.

Checked US East–same thing. Tried US West again, and it was still “Checking Versions” after 6 minutes, so I disconnected.

Internet connection is good, as I can go to other web sites and have no problem. NO VPN.

Tracert to uswest. battle. net went through fine.

What is going on?

30 min later, I can play on US West again. Play for 30 min. Create mule game. Burn it in for 7+ min. Return and drop a few items.

Try to bring in a char and BNet drops everything–game shut down and dropped to desktop. Restart game–hang at “Checking Versions”.

FUN PART:
US West–hangs at “Checking Versions”.
US East–no problems. Waits a sec or two at Checking Versions and then goes to choose acct.
Europe–no problems. Same as US East.
Asia–no problems. Same as US East.

Thus, this is a US West-specific problem.

More fun and games about an hour or so later:

BNet does it AGAIN. Leveled a char. Burned in new game with mule. Brought in char with items, dropped, and did some muling. Maybe 5-6 chars total.

LAST ITEM (nothing valuable, but still…) BNet drops its drawers again.

Try to get back–“Checking Versions”. US East works fine. So, the problem is with US West.

Try to log in to US West again–“Checking Versions”. Left it there at about 12:16pm Chicago time. Checked screen 30 minutes later. No change (still “Checking Versions”).

Thus, something is broken with “Checking Versions” on US West.

It is up to Activision/Blizzard to fix it.

This is also a VERY GOOD INDICATOR of how they will treat customers in the future.

Would YOU buy from such a company? I shall NOT.

It has been a couple hours, and BNet has gotten worse.

When I try to log in to BNet on US West, it hangs at “Checking Versions”. But NOW, when I click on “Cancel”, the game freezes and locks up the computer (only CAD works)–then shuts down D2 completely. At which time, everything else works fine. Can still get to the character login screen on US East, but not US West.

It is now approx 11:30am (Central US/Chicago time) the next day.

Same problem. Sits at “Checking Versions” = infinite loop.

=========================================

At about noon, I decided to fix Bliz’s wagon–my way.

I am using a new PowerSpec Win 10 Pro 64-bit (10th gen I7-10700, 32gb, 1TB SSD M2, 4TB D-drive (empty), Radeon RX 5700 w/8gb memory).

I used the system to remove D2/LOD.
I downloaded (AGAIN !!) D2 and installed it, using my CD Key from my account
I downloaded (AGAIN !!) LOD and installed it, using my DC Key from my account.
I ran Sven’s Glide Wrapper and put it in the D2 directory.
I added -3dfx to the start command.

I tried to access US East, where the system downloaded and updated D2.
I tried to access US West–and got the “Checking Versions” infinite loop AGAIN.

So, this IS a problem with US West. As proven once again.

=======================================

About 3:30 PM Chicago time, I was finally able to get into US West ONE TIME. Of course, it was the wrong account, so I had to try to get to the correct account. And the loop began AGAIN. However, what I did was to go to Europe, get access there, exit Europe, and immediately try to log into US West. GOT IN AGAIN !! So that is what I try to do–but it does not always work. As long as you do NOT change accounts, you can play between the characters on that one account. If you try to change accounts, then you will get the “Checking Versions” loop and might not be able to get back to the game you were in for some time. So, no transferring items between accounts by yourself. But you can reasonably transfer items between characters on the same account.

Meantime, let us see how long it will take for this to get fixed. We now have three people with the identical problem.

===================================
Now 3:30pm Chicago time on 09 April. Problem still exists, but I can sometimes get on if I get onto the Europe or Asia server, exit, and then try to join US West. Other three servers have no problems. There is now (sometimes) a short wait while “Connecting to the fastest server”, but that is maybe 15 seconds. Then it is a crapshoot as to whether or not I get on to US West. I give it up to 30 seconds. If no success, then (successfully !!) log on to another realm server, exit and then retry US West again.

Now we are up to five people with the same problem…

Just tried to rejoin US West. No luck, even after joining other realms. Tracert still shows it gets to BNet–where it times out (which is what it should do).

Tried to get back in a bit later and could not do so. Tried twice with each of other realms (US East to US West, Europe to US West, and Asia to US West). None worked, so I gave up for the rest of the night.

NEXT DAY (Sat, 10 April): First try did not work but second attempt did get me into US West (FINALLY !!). Played char for hours and muled items to characters on same account (i.e. no changing accounts due to inability to reliably join US West). When done, exited account and tried to log back in. No go. Did the change-realm routine, and was finally able to get to account on third attempt. Thus, the problem exists and is persistent over an extended period of time–even after characters have been played for 4+ hours.

Noted response by Customer Service (below). People tend to NOT report problems because they mostly do not get their problems fixed unless there are lots of reports about the same problem. Logging into BNet has long been either GOOD or BAD, and it has mostly been GOOD (unless BNet fails). When BNet fails, the volume of reports tends to be VERY quick and a VERY large number of them. So, fixing the problem becomes a priority. Note the muting of in-game chat last ladder? It is GONE this ladder because of the complaints.

If you are thinking of D2 Resurrected, that does not run as the current D2/LOD does. D2R runs on a different system, so the problems are different. What will those problems be? Don’t know.

Mon, 12 April:

Noon (Chicago time); Just tried to log onto BNet and did so on the first attempt. Perhaps they fixed it? Again, can’t say–but this is a good first sign.

Played a bit, then had to log off shortly after 1:30 (so played for 90 min or so). It is now about 1:45pm, and I can not log in. Same problem as previously: Hangs at “Checking Versions”. Can get to the other three realms (US East, Asia, and Europe)–but not US West. The problem is NOT YET FIXED.

Tuesday, 13 April, 10:30am Chicago time:
I checked a couple of the item-seller web sites. They are also having problems. One is “down for maintenance” and is supposed to be back up on 14 April. Another site says deliveries take 8 hrs–or more.

Have you noticed there are virtually NO BOTS running? All the chant, Baal, and leveling promo/sales-bots are GONE. There are a few that made it through, but when they drop out, they can’t come back (for the same reasons we have problems accessing the game).

Sat, 17 April, approx 2:45pm Chicago time:
Things seems to have improved on USWest, as I am seeing a fair number of bot games (chant, Baal, Diablo) once again.

Was in a game and–once again–got “YCHBI” (Your connection has been interrupted). Am not able to log in to USWest–but the other three realms connect with no problems. USEast seems to have a “…fastest server” issue, as it sat there for 15 seconds (a couple times) until it suddenly changed and I got to the login screen.

USWest has a hang (multiple times) at the same spot ("…fastest server") and then goes on to hang at “Checking Versions” (again). Tried the multiple login tricks a few times but none worked.

Just tried again (after the above post on Sat) and did not get in. Logged into Europe (success), logged out, and tried USWest–success !!

Now my last char on this ladder is completed–unless they get pushed further, which is something that will require serious thought due to the inability to change accounts and move appropriate gear between characters on different accounts (on ladder, of course).

8 Likes

Just wanted to confirm that I’m having this exact same issue. All was fun up until last night.
I even did a fresh reinstall. It took a bit but I was able to get patched to 1.14d and the issues persist.

USEast? no issues. USWest? Checking versions all day.

Thank you for independently confirming this is an ongoing problem that involves more than a single user/account.

Same problem here.
East is ok, Europe is ok, Asia is ok.
West hangs up at “Checking Versions”.

1 Like

I’m having the same issue with US West. I can connect to US East, Asia, and EU successfully. I just reinstalled the game for the first time in about a decade. I’m not on a VPN or a business line, so I’m guessing it’s a server issue rather than an account issue.

1 Like

its already been 2 days. and Blizzard still not fixing this issue. Happening to us west only stucked at fastest to server or checking versions.

1 Like

Same exact issue. I can’t log in to US West, but I went into US East and it’s all fine. Even did a reinstall, run as administrator. Just keeps saying cannot connect to battle.net or gets stuck at checking versions. Glad to hear it’s not just me

1 Like

/bandwagon

Reinstalled Diablo 2 after many years to jump on the hype train. Same issue exactly. US West.

1 Like

Blizzard aware of this issues and planning to fix it? It’s already been 3~4 days.

It’s been happening since yesterday. it stucks at connecting to the fastest server or checking versions and wont go through.

Sometimes you can connect in (extremely rare) but once you logs off from your account it happens again. and it seems like its only happening when i connect to us west realm. east,asia,europe seems fine. I’ve lost my items thanks to this.

Please fix it. Seems like you guys dont give a f about it.

I have run into the same problem, with possibly the same process at fault. I have been playing LOD on this computer for years, with only “normal” issues. Recently applied my old, 2nd D2 license to my daughter’s PC, then bought a gift LOD to install to it as well. Worked fine for ~5 days. Now I get “checking version” incessantly. Sometimes if I cancel/retry (1 or many) it works, other times not. Seems specific to USWest, as I can log in to USEast pretty quickly and consistently.

Unable to get past “Checking Versions” on US West.

As I attempt to log in after the game loads, I choose Battle.net US West, and it goes through two screens, the second of which is “checking versions” and it just goes and goes and goes. (Tried in East, no problem, but none of my accounts are on East). Started D II/LoD again abotu a month ago, no problems once we got the CD keys dug out of the box in the clost.

And now, I can’t get on and play the characters I made as I get myself ready for D II Resurrected.

How does one get past that screen? (Yes I have rebooted multiple times, turned wi fi off then on) … and It Does Not Happen On East.

What’s the trick to getting past that?

Hey all,

For those that are getting stuck at Checking Versions on US West, we’ve seen increased reports of this lately but it seems to be inconsistent.

If it doesn’t work on the first try, does trying a couple of times allow you to log in eventually? From what we can see there are players actively logged in and playing on US West, so it’s not affecting everyone.

Hey Jambrix,

Good to see you. Yes, I can log in with a few tries every time. I just click cancel on ‘fastest server’ and then try again, it goes to ‘checking versions’. I cancel that too.

Game screen freezes for 12 seconds and then goes back to log in menu. I try again and it will eventually go right through to my account sign in.

It takes about 2-5 tries. The key is to ‘cancel’ quickly and keep trying.

Happening to me too, almost exactly like Lionheart, except I haven’t been able to log in yet.

edit: took me about 30 tries but I’m in now… should I never log out?

I am pretty sure its happening to everyone. You have to cancel 3~5 times sometimes even more when it stucks at the connecting to the fastest server or at the checking versions until it goes through.

Yes you can still log in but you have to do this process everytime, you switch your account one to another.

and Everytime you press the cancel button Diablo 2 screen froze for like 7~10 seconds as well.

Just wanted to note: It appears to be working for me on the very first try now. This has been fairly consistent for the last hour with only an occasional hiccup.

Jumping on the bandwagon… having the same issue. Works after cancelling multiple times but all in all could be anywhere between 2-8 cancel attempts. Is it possibly related to the amount of additional players logging in for the technical alpha of resurrected?

I have the same problem on EU.

I have been unable to login since D2R release

As im typing this I am now on attempt 17 of pressing cancel then login and still no go. This issues seems to have lined up nicely with the release of D2R technical go live :frowning:

1 Like