WoW Companion App Error -- June 29, 2021

The WoW companion app is now available for update to 9.1 in the Google and iOS stores and should be working for most players who were previously/recently using the app, but we have come across an issue where attempting to Add an Account results in the app encountering a fatal error. This error may occur for Android users who have updated the app from version 9.0.5 to version 9.1 and:

  • Have not yet logged into the app on their chosen WoW account and are therefore attempting to add a new WoW account.
  • Haven’t logged into the app in a very long time, or for other reasons their WoW account is not pre-populated in the account list and must be added.

We will fix this bug as quickly as possible. Until then, players can bypass the error by uninstalling and reinstalling the app (rather than updating from 9.0.5 to 9.1) and then log in as expected.

5 Likes

In the previous version of the app, in order to switch between accounts, the process used to be: Log out to Char Select
Log out again to Acct Select
Select account

How is that done now? I can’t seem to easily switch from one account to another. Thanks.

Edit: it seems one needs to select main acct name, then cancel to get to account select…

3 Likes

I last logged into the app on Monday (right before the update). I have tried to log in and get the fatal error. I uninstalled and reinstalled and am still getting the error.

17 Likes
  • Have not yet logged into the app on their chosen WoW account and are therefore attempting to add a new WoW account.
  • Haven’t logged into the app in a very long time, or for other reasons their WoW account is not pre-populated in the account list and must be added.

Neither of these reasons apply for me unless you include “for other reasons.” The only “other reasons” I can think of is a Blizzard development related error and not something you can just attribute to user error (e.g., well you didn’t log in recently enough or you didn’t link your account). I was using the app up until the update and the fatal error is still there for me.

10 Likes

Edit: it seems one needs to select main acct name, then cancel to get to account select…

Thanks for posting that. It’s really unintuitive. If Blizzard made that screen that pops up to allow you to choose your other account when you go to the Login screen under your Battle tag #, that would make a ton of sense and be more intuitive, rather than start logging in, and then cancel (which I’ve never had work before) to get to the true account selection screen.

3 Likes

After reinstalling the app, I was able to log in and set my table for one character. On the second character it disconnected and now gets stuck reconnecting to the app.

Edit: just a precursor to All realms down. Nevermind! It directed me to service status forum that doesn’t have a post about the downtime or maintenance, fyi.

1 Like

After updating the companion app yesterday after 9.1 came out, I was able to log in and do my missions on the app. However a day later (this morning), I am getting a fatal error when starting the app.

Things I’ve tried:

  • Cleared the cache and tried again but to no avail.
  • Restarted the phone, but same error.
  • Reinstalled the app but still get the same error message.

I’m on an LG Q7+ phone (Android OS 9).

I was able to find the log file. Here is some of the log and the exception repeats.

[Exception] UnityEngine.AndroidJavaException: java.lang.NullPointerException: baseUrl == null
at UnityEngine.AndroidJNISafe.CheckException () [0x00000] in <00000000000000000000000000000000>:0
at UnityEngine.AndroidJavaObject._Call (System.String methodName, System.Object[] args) [0x00000] in <00000000000000000000000000000000>:0
at Blizzard.MobileAuth.Android.MobileAuthAndroid.Configure (Blizzard.MobileAuth.Configuration configuration) [0x00000] in <00000000000000000000000000000000>:0
at Blizzard.MobileAuth.MobileAuth.Configure (Blizzard.MobileAuth.Configuration configuration) [0x00000] in <00000000000000000000000000000000>:0
at WoWCompanionApp.Login.InitMobileAuth () [0x00000] in <00000000000000000000000000000000>:0
at WoWCompanionApp.Login.SetAuroraPortal (System.String newValue) [0x00000] in <00000000000000000000000000000000>:0
at WoWCompanionApp.Login.Start () [0x00000] in <00000000000000000000000000000000>:0

Edit (7/2): I noticed last night that the app opened, but this morning would crash again. Going in and deleting the data (not just the cache), then reopening seemed to work. I just had to choose to download the assets again. I get one use out of it, then have to clear the data again and download the assets to get back into it after that first use.

Hopefully that can help some people. The clearing the data didn’t use to work but now all of a sudden it does, so there must have been some update of some kind (assets in the app?).

2 Likes

I’m getting ‘fatal error’ even after untinstalling/re-installing. Note9.

8 Likes

I was able to fix the fatal error by changing my region to Europe and then back to US.

1 Like

Hi @Kaivax I am getting fatal error and none of the items you listed as causes occurred so please be aware this error is not limited to those causes. My Fatal Error occurred while I was trying to update the companion app and the app was taking me through the login process on blizzards site and using the mobile authenticator. Which is odd because I was already authenticated and using the app the night before. The app got hung up in the validation process and now is only producing the message Fatal Error when I try and log on and then the app automatically quits. Thanks for fixing this as soon as possible.

3 Likes

Which will only work for one use. Once the app is closed, or if you try to log into another account, “A Fatal error has occurred.”

8 Likes

The causes are not correct. I was neither trying to add a new account nor had been offline for a while - I use the app daily because it’s so much faster than flying six alts from wherever they were. So neither of the causes listed were correct for me. However, I was getting the “a fatal error had occurred” in combination with the blank character list and tried reinstalling… except that it doesn’t seem to want to reinstall. Got to 98% within a couple minutes and has hung there for about 10 minutes now.

ETA, possible progress… fingers crossed…

ETA 2, eventually got it to work. Let’s hope it keeps working after the next restart!

2 Likes

I was logged in after the patch on wow and update to the app yesterday and it worked fine. Now today I only get a fatal error occurred.

2 Likes

That works! Thank you!

Unfortunately, the app crashes before it gets to that point where I can change regions. I’m not sure if others are crashing almost as soon as it starts like me, but hopefully some are able to get around it with this strategy.

6 Likes

I get the fatal error when any Maw adventure does the damage pulse. Also happens on skip to completion. I’ve tried it on two separate characters and it was always the aura damage pulse on maw adventures. I can still use the app for other stuff after, but if i close it, next time starting up immediately get the error and can’t continue.

2 Likes

I tried adding an account when first opened and got a fatal error. Since then I’ve uninstalled 3x and restarted my phone. As soon as I open the app now I get a fatal error and it closes out. Cant do anything else in it. Galaxy S8

2 Likes

I’m still getting the error and the workaround is not functioning properly either

1 Like

I cannot even get past the Download Assets screen, the app is totally unresponsive to taps.

Galaxy S20 here and Fatal error every time since closing after update. I only use one character on one account and have logged into it several times a day for the past few weeks. I did try to login while the servers were down for maintenance and had to reselect my character.