Unable to submit a ticket

I accidentally sold my off-hand. But I can not get to the support page to recover it. any help please.

Have you tried clearing your browsers cookies and cache before reloading your browser? Or trying a different browser entirely? Firefox, Chrome, etc…?


1 Like

I have tried Chrome, firefox and even a different computer with the same browsers. The support page does not load. Cleared cookies and cache on both computers

I even tried to open a ticket in game, but the ticket window will not open to submit a ticket. The link you provided is not loading as well.

1 Like

Do you have any active viral/security programs? It sounds like you are being blocked from reaching those pages.

I’m having the same issue, my priest - torkamada on khazgoroth server is stuck falling through the world when i log onto him and i am unable to log a ticket either ingame or online

1 Like

I checked both computers to make sure the firewall and security programs were not blocking the sites. The site just continues with the swirly circle trying to load the page. Yay! I’m not alone! Sorry for your troubles as well

currently i am on my paladdin sabinus also on khaz, which along with my other toons doesn’t seem to have any logon issues

It looks like we have seen a few reports of folks in a similar situation. It is being looked into, but I’m not sure if it is on our end or on the way to connecting to us. Some folks have had luck using google dns or a VPN, if that is an option for you.


It looks like the link is “slowly” loading from your link. I can now see my characters. I just can’t select the character that is missing the off-hand

Still will not allow me to select the character, but seems to be “still” loading the page.

I don’t know how to set those up. I just want my item restored.

Dug into this a bit more today - we do have contacts open, but this is complicated.

There appears to be a high level internet routing issue - and it may be spreading.

That would be why in these cases, a VPN seems to work for most, it gets around that routing path.

Several symptoms, can’t reach our domain, store, ticket system, games…etc., and it also appears to be periodic for some.

The best way to tell if this might be impacting you is to run a trace…or try a VPN, see if that helps.

1 Like

I’m technically challenged when it comes to pc’s and stuff so I have no idea how to set up vpn’s or google dns.
I have submitted my issue with my priest falling through the world when i log onto him via the bugs option in the ingame help menu because thats the only way i can get a ticket to you.
Can someone please assist.

Any chance y’all are located in the southern US? I have the same issue. We’ve pinpointed it down using a trace-route to the first few jumps having 100% packet loss. Might be due to my ISPs local server blowing up last saturday and the backup server behaving weirdly. If you are located in the same region as me that might be the issue.

1 Like

Hi Zeihel - no, I’m in Australia.

Hmmm that’s strange then. Keep me posted!

Just an add to my post before - I lodged the bug report from my paladdin Sabinus on khaz, which I am currently playing as I get dc’d from my priest before i can do anything on him.

There’s been a few threads in Tech Support regarding connection issues.
A big one involves those that connect thru the Dallas area.

1 Like

I’m on Khaz’goroth which is an Australian server so I’m not sure about the Dallas connection.
It seems unlikely to me that this is my issue though because only one of my toons is affected.

Submitting a Bug Report isn’t going to get your character moved.

Have you tried staying off the character for at least 15 minutes?

Have you tried a UI Reset?

While out of game have you tried:

  • Clearing your browser’s cache and cookies?
  • Tried a different browser?
  • Tried using your phone instead of your computer?

Have you even looked at the steps to use a VPN? You could try Tunnel Bear - from what I’ve heard, it doesn’t seem to be that hard to set up.

1 Like